1
\$\begingroup\$

My PCB has a FT230XS-R USB to UART communicating with an AVR chip. My first prototype board worked perfectly except for the USB problem stated in post title. I triple checked everything. Can NOT find why I'm getting this error. This may be a design flaw on my side? I followed the "Self-Powered" configuration on page 23 in the datasheet exactly as displayed.

Things I have checked:

Solder bridging?: Everything is reflow soldered, I still checked under microscope, it's perfect.

Still used a MM to check for shorts: None.

Checked cable: Good

Power supply quality: < 2mV peak to peak

Correct USB connector pins go to correct inputs: Yes

I triple checked the pinout on the datasheet against my PCB: Everything's correct.

I checked ground, VCC, and VCCIO values. Everything's normal.

I remade a PCB, I left every component unpopulated except for the FTDI chip and peripheral components needed to run the chip. Still had the same problem.

I tried removing RX and TX LEDs: Nothing.

I then removed 47pF caps and 27 ohm resistors: Nothing.

I am at a loss. I contacted FTDI. They only said I have a short somewhere, and they asked for a schematic. I sent them the schematic, never heard back from them.

Could vias on my USB signal lines be corrupting the signal? Any info is greatly appreciated. I uploaded only relevant schematics and PCB design snapshot.

Please ignore U9 and pads directly above it, they are unpopulated. They were never populated for either test.

Thank you so much.

PCB Design

Schematic

\$\endgroup\$
17
  • \$\begingroup\$ Are you confident with the FTDI chips supplier? They're so popular there must be plenty of fakes out there. \$\endgroup\$
    – carloc
    Aug 3, 2019 at 7:52
  • \$\begingroup\$ Your schematic does not tell the whole story, as the layout shows. On the schematic, I see pin 3 of J4 going directly to pin 8 of U5. On the layout instead, I see the tracks going through the RC as per the datasheet. I also see a U9 connected to D+ and D-, what is that about? Please, post a complete and correct schematic if you want help. \$\endgroup\$ Aug 3, 2019 at 8:21
  • \$\begingroup\$ How is the FTDI chip powered? Is it meant to be bus powered because your cct isnt \$\endgroup\$
    – user16222
    Aug 3, 2019 at 9:00
  • \$\begingroup\$ The schematic and layout don't match. \$\endgroup\$
    – Turbo J
    Aug 3, 2019 at 9:48
  • \$\begingroup\$ These boards can have Windows and Linux and Android drivers, but not likely all 3. Are you certain of the drivers installed? \$\endgroup\$
    – user105652
    Aug 3, 2019 at 10:35

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.