0
\$\begingroup\$

I did a bistable multivibrator drive NPN mosfet using timer55 and my mosfet drive power LED. Our Load has 3 circuit stage which are emc filter + smps circuit + power Led. I have a problem at that time my mosfet turn off. When mosfet turn off a clicker happens on my Led. Large capacitive loads are discharhing and mosfet behaves like turning on. I dont know how to handle this problem and want to know are there anybody to had this problem ?

schematic

simulate this circuit – Schematic created using CircuitLab

I tried you illustrate my circuit in your mind.

\$\endgroup\$
15
  • \$\begingroup\$ What are the values of your capacitors? Try placing a diode across L1 with the cathode connected to C1 and the anode to C2. Your FET gate needs a pull-down resistor (gate to source) if you don't have one, otherwise it can float on easily. \$\endgroup\$ – John D Sep 11 '19 at 19:15
  • \$\begingroup\$ I tried to put resistor from gate to ground but it doesnt matter. Two 47uF and two inductor at uH levels i didnt look actually. There is something need take attention; when below 24Volts smps draws 20-30 mA more than nominal voltages which is 28VDC and flicker dissapared. \$\endgroup\$ – IHK Sep 11 '19 at 19:23
  • \$\begingroup\$ Diode like 1N4007 or schottky ? @JohnD And if i ask you, can u draw what i have to do and explain the reason to put these diodes. \$\endgroup\$ – IHK Sep 11 '19 at 19:39
  • \$\begingroup\$ I am not sure why you need the PI filter (CLC). The MOSFET is not driving a lot of current. Can you eliminate C1 and L and place C2 near LED. \$\endgroup\$ – Rob B. Sep 11 '19 at 19:39
  • \$\begingroup\$ To eliminate emc problems. Automotive standarts are to heavy. Btw this current draws from input of smps, power led draws 600mA at output. \$\endgroup\$ – IHK Sep 11 '19 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.