1
\$\begingroup\$

I am currently trying to get my Bus Blaster v4.1a to work. I want to use openocd to communicate with a device over JTAG. The device that I want to communicate with is a Qualcomm_qca4531.

First of all let me show you the command that I enter in the terminal just in case that I am already doing something wrong here:

~/openocd/tcl$ sudo openocd -f interface/ftdi/dp_busblaster.cfg -f target/qualcomm_qca4531.cfg

The 2 config files that I am using were already provided by openocd and can be found here:
https://github.com/analogdevicesinc/openocd/blob/master/tcl/interface/ftdi/dp_busblaster.cfg
https://github.com/ntfreak/openocd/blob/master/tcl/target/qualcomm_qca4531.cfg

The error that I am receiving from OpenOCD right after entering the command is the following.

Open On-Chip Debugger 0.10.0+dev-00936-g0a13ca1a (2019-10-10-09:36)
Licensed under GNU GPL v2
For bug reports, read
    http://openocd.org/doc/doxygen/bugs.html
Info : If you need SWD support, flash KT-Link buffer from https://github.com/bharrisau/busblaster
and use dp_busblaster_kt-link.cfg instead
adapter speed: 2000 kHz

Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.
qca4531_ddr2_550_550_init
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : clock speed 2000 kHz
Error: JTAG scan chain interrogation failed: all zeroes
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: qca4531.cpu: IR capture error; saw 0x00 not 0x01
Warn : Bypassing JTAG setup events due to errors
Info : Listening on port 3333 for gdb connections

I already checked a few things:
I checked if any of the JTAG Pins is shortened to gnd or vcc. They aren't.
I also tried to use urJTAG to communicate with the device, it doesn't work either but I receive a different error: TDO seems to be stucked at 1.
I also checked if I connected the right pins. I have 6 pins that I have to connect. VCC, GND, TMS, TCK, TDI and TDO. There are only these 4 JTAG pins on the board but after a little research I found out that I only need these 4 pins, TRST and other JTAG pins are optional so I think there should be everything fine with the connection.
I can also confirm that the Bus Blaster supports the same voltage levels as my target device. (3.3V)

Can you think of any other reason why I get the error mentioned above?
Is it possible that JTAG is deactivated on the target device? I tried to find out what openocd output looks like when JTAG is deactivated but I can't find anything helpfull.

Thanks to everyone in advance.

\$\endgroup\$
  • \$\begingroup\$ What I can read "OpenOCD will only work with the libUSB drivers" Might be worth checking ? Worth a read - dangerousprototypes.com/docs/Bus_Blaster_OpenOCD_guide \$\endgroup\$ – Sorenp Oct 11 '19 at 8:39
  • \$\begingroup\$ If the device has a TRST connection (it is optional in the spec but is often implemented) then you will need to drive that pin (I do not know if your device actually implements TRST) \$\endgroup\$ – Peter Smith Oct 11 '19 at 8:41
  • \$\begingroup\$ @Sorenp I will check that out. \$\endgroup\$ – Ramazuri Oct 11 '19 at 9:05
  • \$\begingroup\$ @PeterSmith The device does not have a TRST connection. It only has the 4 pins (TDI, TDO, TMS and TCK) for the JTAG connection. I checked that in the datasheet. \$\endgroup\$ – Ramazuri Oct 11 '19 at 9:07
  • \$\begingroup\$ @Sorenp Edit: I checked it out because I was not sure if I have installed libUSB but I had. So that shouldn't be the cause of the problem \$\endgroup\$ – Ramazuri Oct 11 '19 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.