0
\$\begingroup\$

I'm trying to run a 6V/1A motor from a 5V/2.2A USB battery pack (i.e. a phone-charger battery bank).

I'm using a Pololu boost converter to make 6A (>80% efficiency), but the motor never starts, it just makes a stuttering 'glitch' noise.

I've tried putting big smoothing capacitors over the voltage lines in case inrush voltage drops were causing problems.

Any other ideas: circuits, protection diodes, etc? Thanks!

EDIT: Hi everyone, thanks for all your input. 1) I don't have a spec sheet - it's about the size of a D-cell battery and has a sticker saying Made in Germany, 6V/1A on it. 2) Trying to add it to an existing bit of kit which runs off a USB battery pack (the motor doesn't start even with this other kit removed), 3) Tried a few other USB batteries, some work, some don't - quality/brand name doesn't matter , 4) I'll give a floating battery/supercap a go and report back.

\$\endgroup\$
  • \$\begingroup\$ I will ask the moderator to change it to electronics stack exchange \$\endgroup\$ – Michel Keijzers Oct 28 '19 at 17:03
  • \$\begingroup\$ Do you mean 6A or 6V? (for the Pololo boost converter)? \$\endgroup\$ – Michel Keijzers Oct 28 '19 at 17:04
  • 2
    \$\begingroup\$ Please provide links to the datasheets for the motor, the battery pack, and the boost converter. Have you measured the actual voltage at the motor terminals? \$\endgroup\$ – Elliot Alderson Oct 28 '19 at 17:37
  • \$\begingroup\$ Most likely the startup current of the motor is high enough to cause the converter to shut down. Without more details, we're just guessing. \$\endgroup\$ – Phil G Oct 28 '19 at 18:09
  • \$\begingroup\$ Using a boost converter for a motor is rarely a good idea. Likely you've just bought the wrong assortment of components. Your simplest solution is likely going to be some number of AA cells, primary or possibly NiMH moved between your project and an external charger. \$\endgroup\$ – Chris Stratton Oct 28 '19 at 18:20
1
\$\begingroup\$

I had a similar problem using a Pololu boost regulator to drive a motor. Placing capacitors before and after the regulator made the problem worse. The regulator drew a lot of power but failed to reach the full output voltage.

My conclusion was that the high initial load caused the bench power supply current limit to kick in, at several times the expected working current. This caused the regulator input voltage to drop within 5-10 ms of start. I assume the regulator at this point would work even harder to compensate for the voltage drop. This apparently ruined some feedback loop of the regulator, putting it in a locked-up state even though the steady-state power draw would be well supported by the power supply.

Increasing the current limit of the power supply solved the problem. So I suspect the peak current rating of your USB battery bank. Check with another power source. Also, my experience with USB cables is there's a wide difference in cable quality (= resistance), which also could be detrimental to the initial current in-rush.

If possible, monitor input and output voltage from the regulator with an oscilloscope. The events the first 15 milliseconds were very revealing for me.

EDIT:

Tried a few other USB batteries, some work, some don't

Then you already found a solution. I might have been able to contribute the 'why'.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ I came to a similar conclusion about the initial power surge - moving to a wall-wart USB output worked fine - but I like your voltage drop causing the boost to compensate harder explanation. yeah - I guess I do have a solution, but the trial-and-error power-bank fix is deeply unsatisfying (not to mention expensive!) \$\endgroup\$ – Dave Issacs Oct 29 '19 at 15:51
  • \$\begingroup\$ It you have an oscilloscope, you can do "trial-and-measure" instead. Without detailed specifications of the battery banks, motor and regulator, solving the problem by theoretic calculation is not possible. \$\endgroup\$ – Anders Petersson Oct 29 '19 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.