1
\$\begingroup\$

I have vias connected to the polygon. In the old design (left pic) the vias have annular rings. But I modified few other things in the PCB. I removed unused vias in both new and old design. But now in the new one (right picture) the vias don't have the rings showing up. I guess, it doesn't make difference for the manufacturer? But also, I don't know why is it happening.

enter image description here

\$\endgroup\$
1
  • \$\begingroup\$ Please show the properties window for the problem vias. Also, is the copper surrounding them on the same or a different net from the vias? Also, are both types actually vias, or is one of these structures a pad (as defined by Altium)? What are your polygon connection rules for vias and for pads? \$\endgroup\$
    – The Photon
    Nov 8, 2019 at 16:34

2 Answers 2

2
\$\begingroup\$

If you check off “tented” in the via properties on the relevant side the solder mask will not be pulled back around the via, so it will look different in both the layout and when it is fabricated.

See, for example, this answer.

There are various reasons to prefer one over the other, but that’s outside the scope of this answer.

\$\endgroup\$
3
  • \$\begingroup\$ This is internal layer. Vias are tented in both old and new design. \$\endgroup\$
    – zwtyl
    Nov 8, 2019 at 11:14
  • 1
    \$\begingroup\$ Are the padstacks for the vias identical? \$\endgroup\$ Nov 8, 2019 at 11:16
  • \$\begingroup\$ Yes. The are simple vias. I only removed the unused pads from Altium. But I was on both old and new design. It seems like some setting in Altium to me. \$\endgroup\$
    – zwtyl
    Nov 8, 2019 at 14:12
2
\$\begingroup\$

I had this same issue and found the solution here after some digging: Greyed out vias in altium

The solution is: Tools >> Remove Unused Pad Shapes >> Scope = Both(vias in this case) , Operation = Restore Unused

Not sure what caused this issue initially but now all my vias have annular rings on all layers again.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.