1
\$\begingroup\$

Complete schematic: enter image description here

Top part: enter image description here

Lower part: enter image description here

This is the circuit schematic, top part is sensor, bluetooth, microcontroller, oled and pins related all working from 3.3v coming from regulation of a charge pump; bottom part is power regulation part, smart load sharing for LiPo, battery charging and battery protection circuit (though battery has its own) and ESD protection from DC barrel jack.

I am using TP4056 as battery charger, stm32f103c8t6 (ordered from LCSC) as uController, 82402305 for esd protection and ltc3240 as a charge pump below 3.3 volts and voltage regulator above that up to 6 volts.

After a few stable uses the system smokes and at some point each of this components has been found shorted, three times the system has failed being the first time the uController the one which failed through shorting and minimally heating(though I didn't use the system as expected and injected voltage several times through OLED pins and power switch and I think I could have connected something wrong so it was my fault) and the second and the third time being the tp4056 the one which first smoked and shorted immediately after connecting dc barrel jack (polarity and voltage checked in open circuit) with the curiosity that the third time something happened (I let dc barrel jack connected longer compared to second time where I saw the smoke and disconnected it immediately) that made ESD protection, ltc3240 and uController short (which makes me believe that tp4056 is not the problem but something in the uController) with the fact that neither bluetooth, sensors nor OLED screen have ever damaged.

More detail:

1st fail: Soldered everything, injected 3.3 volts through oled pins and 5v through switch so it passed through charge pump so I could test it; after several time of using the system (programming it and related stuff) found a short after and OLED not displaying anything, ARM cortex is shorted, changed it and everything works (it maybe was my fault but ARM cortex is found damaged on third fail though)

2nd fail: Tp4056 smokes after connecting barrel jack now I decide not to inject voltage, a short is detected, tp4056 is the fault, change it, everything works again and achieve one complete charge cycle from 3v to 4.2 volts.

3rd fail: Battery drains to 3v I connect barrel jack-> magic smoke, 1 short but this time 82402305, tp4056, ltc3240 and arm cortex are shorted, remove and change, everything works again

Thanks for your precious time

\$\endgroup\$
  • 1
    \$\begingroup\$ I see pin 9 (called EP) of the TP4056 has been left unconnected in your schematic. I assume this is the Thermal Pad. How did you connect this pad on the PCB? \$\endgroup\$ – Huisman Nov 18 at 6:56
  • \$\begingroup\$ It is soldered to the pad with solder paste even though the pad is not connected to anything. I've seen some people do not solder it and have no problem \$\endgroup\$ – Paul Max Avalos Aguilar Nov 18 at 7:03
  • \$\begingroup\$ TP4056 has abs max V of 8V so >> 76V max Vin. There is NO high power high current path through TP4056. Best conclusion is that you are over-voltaging it. What is your ACTUAL Vin BEFORE you load it down? \$\endgroup\$ – Russell McMahon Nov 18 at 7:47
  • \$\begingroup\$ Before loading down it is 5v ~4.9v \$\endgroup\$ – Paul Max Avalos Aguilar Nov 18 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.