1
\$\begingroup\$

This question is in regards to the PCB editor of Altium Nexsus 2.1.7.

When moving a routed room (A) over another routed room (B) and then moving the room A again (I.e. pausing over room B by releasing the LMB), the traces B are then moved with room A. In other words, B's tracks are transferred into A.

I would expect the traces to stay with the room that they were routed in originally. Is there any way to achieve this? I.e to assign tracks to rooms such that they cannot be transferred to other rooms?

Curiously, when selecting "RMB->Room Actions-> Select Room connections" on room B, only the original traces of B highlighted, the "stolen" tracks of A are not...

It is a very similar issue to what was asked here (No resolution): https://www.edaboard.com/showthread.php?377851-ALTIUM-Move-room-without-moving-other-layers-track

\$\endgroup\$
0

3 Answers 3

1
\$\begingroup\$

A really dumb workaround which I found uses what is probably another bug: The fact that if you select an object or a track and then a room only that object and the room polygon will be moved.

So by selecting the components and tracks of the room first. And then selecting the room, all components and tracks of that room can be moved without disturbing any other traces. Disclaimer: I have no idea if this method has any negative consequences.

This is the easiest method that I have found for achieving that selection combination for a room which is over other tracks and components on other layers:

Step 1: Select Components: Done once: To prepare we need to be able to cross probe multiple components at once: Enable Prefrences->System->Navigation: Check cross Selection box.

Go to the schematic instance of the room you want to move and hit Ctrl+A in that sheet instance. This selects the components of the room in the PCB editor since we enabled the auto crossprobe function.

Step 2: Select the tracks: Go to the PCB editor and right-click on the room that should be moved WHILE holding shift:

RMB{in room while holding shift}->Room Actions->Select Room Connections

Now you can release shift, both the components and the tracks should now be selected.

Step 3: Selecting the room: Shift LMB click on the room to select it. Now the room, the components, and the tracks are all selected.

Step 4: Move the room: You can now move the room and its tracks without moving any other tracks.

Stupid? Yes.

\$\endgroup\$
0
\$\begingroup\$

This is, by far, the most annoying "feature" of Altium.

Another workaround you can do is select the room and everything inside that you wish to move (use View Configuration to filter what you see to use 'Select Inside' for example), press 'm'-> 'Move selection by X, Y...'. This movement will not steal anything from overlapping rooms.

\$\endgroup\$
0
\$\begingroup\$

Also you can select room, components and tracks inside room and move it using CTRL+ARROWS (Altium 21).

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.