2
\$\begingroup\$

I am trying to make nixie clock and I use MC34063 for buck/boost converters. The nixie tubes require 180 V to operate and the microcontroller and LEDs need 5 V. I use external 20 V power supply as a source. Here are the circuits:

5V enter image description here

180V enter image description here

When the circuit is powered I can hear an annoying audible noise. The sound comes from all small SMD capacitors. It sounds something like 13 kHz sine wave. I power the raspberry pi from the 5V line and it's capacitors become noisy too.

I have tried to change 100 uH coils to 220 uH, but it didn't change anything. Please help.

Here is a link to full project and PCB design for more info

UPD1: The external power supply is not the issue. I tried to power the circuit from a different one and even from a 12V LiPo battery and the noise didn't change.

UPD2: I measured the frequency of the timing capacitor charge/discharge:

The 180 step-up converter is running at 47 kHz enter image description here

The 5v step-down is running at 49 kHz enter image description here

I also noticed a weird behavior of 5V's timing capacitor when the LEDs are on enter image description here

UPD3: here I found that capacitors used in switching power supply should be low-ESR. I am not sure, that my capacitors fit this rule. Here are the datasheets of my capacitors:

220uF: https://lcsc.com/product-detail/Aluminum-Electrolytic-Capacitors-SMD_220uF-35V_C3340.html

4.7uF: https://lcsc.com/product-detail/Aluminum-Electrolytic-Capacitors-SMD_4-7uF-400V_C88703.html

100uF: https://lcsc.com/product-detail/Aluminum-Electrolytic-Capacitors-SMD_100uF-35V_C88675.html

UPD4: I swapped all my electrolytic capacitors with low ESR ones, but the noise didn't change. I measured the voltage ripple of 5v line, it wiggles in 300mV window at approx 4kHz: enter image description here

\$\endgroup\$
  • \$\begingroup\$ Are you sure that C65 is the correct value? 510pF should yield an operating frequency of 50kHz, 5.1nF would be more like 10kHz. \$\endgroup\$ – Spehro Pefhany Jan 8 at 2:05
  • \$\begingroup\$ Maybe I should really change the timing capacitor. But are you sure that the capacitance should be increased? More capacitance = more time to charge = lower frequency. Am I wrong? \$\endgroup\$ – George Jan 8 at 11:40
  • 1
    \$\begingroup\$ I’m suggesting the capacitance should be as marked on your schematic, but might, in fact, be larger. \$\endgroup\$ – Spehro Pefhany Jan 8 at 15:10
  • \$\begingroup\$ Are you saturating your inductors by any chance? \$\endgroup\$ – winny Jan 10 at 13:39
  • 3
    \$\begingroup\$ @Vinzent there is a piezo-electric effect in ceramic MLCC caps. Couldn't be this the reason? \$\endgroup\$ – Chupacabras Jan 10 at 14:33
5
+25
\$\begingroup\$

Whine or high-pitched whistling usually comes from coils and ceramic caps.

Coils whine due to magnetostriction: core material expands and contracts according to the magnetic field, so they convert current ripple into sound.

High-K ceramic caps (ie, not C0G) are piezoelectric: they expand, contract and flex depending on the voltage applied to them, which means they convert voltage ripple into sound. This is reversible, which makes them unintended piezo microphones sometimes. Ceramic caps are a well known annoyance, and manufacturers offer lots of options like "low noise caps" (example) or "flexible terminations" to mechanically decouple caps from board.

The noise can only be heard when it occurs at an audible frequency, which at first glance should not happen in your design because both converters run well above the audible range.

Usually the offender is a switching power suppy in standby mode. While it switches at say 50kHz when it's on, at low load current, it may go in and out of sleep mode at a frequency that will be audible. Magnetostriction will make the transformer whine, and increased voltage ripple will make the ceramic caps also whine. So first check the culprit is not a switchmode supply. You can add a load on the output, or use another supply.

Now since that probably didn't solve your problem...

Hypothesis 1: Beat Frequency

According to MC34063 datasheet, frequency isn't very accurate. With the example 1nF capacitor it can vary widely, in a +/- 27% range.

enter image description here

With 510pF cap we should have about 50kHz but probably the same error range, ie between 36 and 63 kHz.

enter image description here

Thus it is possible to have a 13kHz frequency difference between both chips, which would create a 13kHz beat frequency ripple on your "+12V" power supply which is labeled +12V on the schematic and described as +20V in the question.

This can create 10kHz ripple on your input supply voltage and make the ceramic caps sing. If the layout is not good, for example input and output couple through GND, or the spot where the feedback network connects to GND has high voltage ripple, then this ripple can also leak into the output of the DC-DCs and make all the capacitors everywhere play a tune.

So, to check if my hypothesis is correct...

If you have an oscilloscope, check the frequency of each converter and check voltage ripple on the input supply. Do you find 13kHz beat frequency?

If you don't have a scope, change one of the 510pF caps that set the switching frequency of your chips. You can solder, say a 100pF cap right on top to make it 610pF. This should change the frequency a bit, so if the problem is due to audible beat frequency between your converters, this will change the frequency of the audible tone.

If this works then you've found the problem. You can either do it right and add enough proper caps on the supply to flatten that ripple... or you can wing it and tweak the frequencies of both converters until their difference is no longer audible...

Hypothesis 2: Raspberry Pi

If the Pi has a 13kHz ripple in its power supply current, that can also cause voltage ripple on your supply. You could try powering the Pi from a separate supply, see if that changes the noise.

\$\endgroup\$
  • 1
    \$\begingroup\$ I tried to power the raspberry pi from another source. The RPi capacitors are completely silent now. But the clock's are still noisy. I updated my question with some measurements \$\endgroup\$ – George Jan 11 at 20:02
  • \$\begingroup\$ Great! If the noise from the Pi disappears when it is powered from another source, this does point towards ceramic capacitor noise due to voltage ripple. Can you measure ripple on +5V and +20V? Also you need low ESR caps for switching converters. \$\endgroup\$ – peufeu Jan 11 at 21:01
  • \$\begingroup\$ I swapped my current capacitors with low ESR ones and that didn't change the noise much. Maybe it didn't change at all. I will measure the ripple and update my question \$\endgroup\$ – George Jan 13 at 22:55
3
\$\begingroup\$

What you are hearing is most likely the piezo-electric effect from the MLCC capacitors - as various other comments and answers stated.

Your oscilloscope shot shows a 3.81 kHz oscillation with 300 mV on the 5 V line. This is very much audible. As your switching frequencies are all outside the audible range, the source of the oscillation is very likely from an unstable (or marginally stable) control loop.

I suggest, that you debug the buck and the boost separately. Turn of/disconnect one and work with the other. You alter the control loop by playing with C59 (in case of the5V buck) and C67 (for the 180 V boost). Increase those slightly and observe the 3.81 kHz with 300 mV amplitude on the 5 V. Does it change? Getting smaller? Then we are on the right track. Disadvantage: increasing those caps makes your control loop slower, and react slower to input voltage fluctuations and load changes. Might not be an issue for you though.

Good luck & keep us posted. ;-)

\$\endgroup\$
3
\$\begingroup\$

According to Onsemi conductors PDF manual for this IC, page 5, this IC has a ripple at the output of 400 mV. Their designs often suggest use of a low value inductor (LC network) to remove most of such ripple. However inductors and capacitors before any extra filter are subject to whine and chatter. This should only affect a few parts, and you CANNOT make magnetostriction go away. Keep those parts to a minimum and add an extra inductor and capacitor so the ripple is at least "trapped" close to the IC. If installed in a sound-tight enclosure such a whine could be dampened a lot.

The MC34063 IC is ancient, limited to 42 KHZ at most, and does not offer pulse-stealing and other tricks to be efficient at low current levels. Try using a resistor that presents a 1% to 10% load to see if it changes the nature of the noise. Ultimately you cannot make this noise zero db in sound level. Suggest using a more advanced IC with pulse-stealing and a much higher frequency of operation.

When you buy or use a particular switch-mode IC you are also buying its faults and imperfections. You have to decide what is really important, a tough job for any design engineer.

It is worth it to shop for better grades of capacitors and inductors sealed with enamel to cut down on whine and chatter, but at some point you have diminishing returns. At some point you have to accept whatever residual noise you have left, even if you manage to reduce it by a good amount like 75% or more.

I question the low value capacitors being used, compared to the high value low esr electrolytics shown in On semiconductors pdf, above which the link is provided. The design account for the low switching frequency by using capacitor values MUCH higher than what we would use with current day switch mode IC's. Your design uses a MOSFET to boost power level, but it is the same IC. Low value MLCC capacitors may not be able to filter ripple and chatter as expected. I would at least try the high value (must be low esr) electrolytic capacitors as shown in the diagram, rated for the voltage you have as an output.

In my opinion the capacitors being used in the 180 volt version are 10 times too low of a value, and several in parallel create a very low esr. 100uF should be several 220 uF in parallel. The 400V 4.7 uF should be several in parallel or a few 400V 22 uF in parallel. Also add the extra filter stage as shown. You need to work at this to get what you want.

enter image description here

This image is from page 5 of ON semiconductors MC34063 pdf manual.

\$\endgroup\$
1
\$\begingroup\$

1) All your noise problems come from two issues:

  1. Timing cap* inductor pair are too big. Reduce L 20uH to 33uH low DCR. Move up to 30 kHz. I suspect you have resonance with your 4.7uF load and 100uH.

  2. The e-caps are STD rated for low ripple current and must be low ESR. Thus the current is limited and the piezo ceramic caps are audible with too much current force. Replace all E-Caps with low ESR. Add more ceramic caps to share the load current and reduce stress.

    • This means they are STD ESR caps not low ESR. C*ESR =T should be 1< T < 10us. This will be evident by Ripple current ratings of 700 to 1500mA (RMS) instead of these low rms caps.

enter image description here

As a result the ceramic are taking the brunt of the spectral noise caused by the FET. Ic=CdV/dt

\$\endgroup\$
  • \$\begingroup\$ I have bought low ESR electrolytic capacitors and will swap them today. If this doesn't help, I will try to change the timing cap and inductor pair. Do you mean that the inductor coil should be 20uH or it should be 20uH less than my current one? I have tried 100uH and 200uH coils with the same noise. \$\endgroup\$ – George Jan 13 at 14:28
  • \$\begingroup\$ Increasing L lowers resonant f \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jan 13 at 14:38
0
\$\begingroup\$
  1. How do you know the noise is 13KHz?
  2. On the compensation pin, there is a 0.1uF capacitor in each circuit (C59 and C67). Will it cause the control loop unstable?
  3. If the beat frequency is the cause, shutting off the one will eliminate the noise totally. Or, changing the load from very light to heavy should change the noise level, even frequency, significantly.
\$\endgroup\$
  • \$\begingroup\$ How do more questions answer the OP's question? \$\endgroup\$ – Sparky256 Jan 17 at 4:38
  • \$\begingroup\$ 1. I launched a sine wave sound generator like this one onlinetonegenerator.com and played with the frequency until the sound matched with the circuit's whistleing. 2. I have a very weak knowledge about MC34063. Tell me what capacitor should I use and I will try it. 3. I will try to shut down one converter today. By the way, the noise changes when my LEDs under the lamps shine brighter. I can even hear changes in noise when I type commands to the raspberry pi's terminal over SSH. \$\endgroup\$ – George Jan 20 at 14:37
  • \$\begingroup\$ @Sparky256, sometimes a correct question helps a lot in debugging the problem \$\endgroup\$ – George Jan 20 at 14:43
  • \$\begingroup\$ Thanks for sharing the onelinetonegenerator method. I'd like to try totally removing C59 and C67. \$\endgroup\$ – X J Jan 20 at 18:25
  • \$\begingroup\$ @George. It was not to be fussy George. Typically questions are put in comments, as they are not an answer, but a prompt to help get better answers. Note that I did not down vote XJ for going off-base. \$\endgroup\$ – Sparky256 Jan 22 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.