8
\$\begingroup\$

I am trying to use a transistor to drive a lamp from a Raspberry Pi (3B+) and I went after one that can be switched by the 3.3V logic. I found the FQP50N06L to have a max Vgs threshold of 2.5V, so it should work (right?). Here's the circuit I am using:

schematic

simulate this circuit – Schematic created using CircuitLab

The lamp is rated 0.75A @ 5V, so this setup should be working, but it's not. The lamp turns on if I use 5V at the gate and goes dim for 4.5V or so.

I would suspect I chose the FET poorly, but I'd appreciate someone else's input on the matter before going hunting yet again for another transistor and found out the circuit is wrong.

So what could be the problem here?

EDIT: Yes, I forgot the word "threshold" on "max Vgs threshold."

\$\endgroup\$
  • 1
    \$\begingroup\$ It seems like it should; I'm not sure what C1 is doing, but the datasheet says you should be able to pull an amp with 3.3V on the gate. Can you check the gate and source voltages when it's supposed to be on? \$\endgroup\$ – Cristobol Polychronopolis Jan 29 at 21:12
  • 2
    \$\begingroup\$ Max VGS of 2.5 is the actvation threshold. The MAX gate voltage is 20V. You need a Logic Level FET \$\endgroup\$ – Natsu Kage Jan 29 at 21:26
  • \$\begingroup\$ What makes you assume falsely that "setup should be working," when you need at least 2*.Vgs(th) \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jan 29 at 21:35
  • 1
    \$\begingroup\$ If the drain voltage isn't pulling all the way down near zero, M1 may be operating in a linear mode and can burn up easily. Don't leave the circuit on for more than a few seconds. \$\endgroup\$ – Mattman944 Jan 29 at 22:06
  • \$\begingroup\$ On that application, I always end up using the IRLZ44N FET. \$\endgroup\$ – orithena Jan 30 at 9:29
17
\$\begingroup\$

If the lamp is really 0.75A @ 5V, then it's resistance is closer to 7 ohms (when hot).

The Vgs of 2.5V is the threshold, where it will just start to conduct, so you have not chosen a good MOSFET. However, it probably would work, if the load resistance was a constant 7 ohms. But, it is not a constant 7 ohms, a cold filament can have 10 times less resistance than a hot filament. So, you never get enough current to heat up the filament.

enter image description here

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ That makes sense! Thank you for the explanation! \$\endgroup\$ – Lurosset Jan 30 at 11:26
  • 1
    \$\begingroup\$ The Y-Axis of your figure starts at 1 A \$\endgroup\$ – sstobbe Jan 31 at 2:31
  • \$\begingroup\$ @sstobbe - good catch. So, my graph isn't exactly correct. But, the evidence supports a cold filament issue. The assumptions can probably be changed to get the graph to work. For example, I used the 3.5V Vgs curve (logic is 3.3V); the cold resistance could be 15X less instead of 10X (someone documented an experiment where it was 15X); maybe the GPIO puts out a little less than 3.3V; this is a typical graph, not a guarantee, ... \$\endgroup\$ – Mattman944 Jan 31 at 3:12
  • 1
    \$\begingroup\$ @Lurosset - here is an experiment to verify the cold filament theory. With the gate at a logic high, short the MOSFET Drain to Source for a few seconds. Of course, the lamp will light while the short is in place. See if the lamp remains lit when the short is removed. \$\endgroup\$ – Mattman944 Jan 31 at 3:17
  • \$\begingroup\$ Regardless, you still authored a lovely answer. Just not sure what the actual root cause is if the lamp is dimly lit with a 4.5V Vgs, as the op expresses. \$\endgroup\$ – sstobbe Jan 31 at 3:24
11
\$\begingroup\$

I found the FQP50N06L to have a max Vgs of 2.5V, so it should work (right?).

2.5 V is not the 'max' Vgs, it is the threshold voltage at which the FET should draw at least 250 uA when Vds is 2.5 V, ie. the point where it just starts to turn on.

Your FQP50N06L may be at the upper end of its spec and/or there might be some voltage drop in the Gate circuit (check your resistor values), but a 'Logic Level' FET is rated for Gate drive voltage of 5 V, not 3.3 V. For reliable operation at 3.3 V you need a FET which is rated for a Gate drive voltage of 2.5~3.0 V.

Another thing to bear in mind is that an incandescent Lamp has about 10 times lower resistance when cold, so the initial current when turned on may be up to 10 times higher than normal, ie. ~7.5 A for your '0.75A @ 5V' bulb. If the circuit cannot supply this current then the bulb may turn on slowly or not at all.

| improve this answer | |
\$\endgroup\$
6
\$\begingroup\$

2.5V is the gate-source voltage threshold which is where it just barely starts to turn on. You want your applied voltage to be considerably higher than that. Go by the gate voltages used to obtain the rated RdsON, not the gate threshold voltage. enter image description here

You can also go by the I-V curves in the datasheet and calculate the resistance from the slope if you want to obtain the specific values at other operating points (such as 3.3V which is above the threshold but below what was used to get the rated RDson.

At Vgs = 3V, the slope looks like it is 50-100mOhms, depending on which point you decide to go R = V/I. Better than I thought it would be. You would think it would work but perhaps its too borderline or something else is going on.

EDIT: Mattman944 has an explanation as to why.

enter image description here

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ I'll keep the ON characteristics in mind, then! Thank you! :) \$\endgroup\$ – Lurosset Jan 30 at 11:28
2
\$\begingroup\$

Reduce R1 to 100R to drive the gate harder. Lose the capacitor across the lamp. It is all to do with the mosfet gain. I would also move the 100k resistor to the left side of R1. It currently acts as a potential divider, although the effect is minimal with these resistor values.

| improve this answer | |
\$\endgroup\$
1
\$\begingroup\$

A MOSFET is a linear device controlled by voltage. At 2.5V this MOSFET only just turns ON, and conducts just 250uA current .. Which is insufficient for to turn on the lamp, If you want more drain current increase the gate voltage according to VI characteristics.

Use a much smaller gate resistor. like 5~10 Ohm, & remove 100K resistor. No need for it here because your switching is very slow I think. If your switching is fast then only use gate to source resistor to provide discharge path for mosfet when it off.

| improve this answer | |
\$\endgroup\$
1
\$\begingroup\$

As DKNguyen is writing, the VGS voltage condition at RDSon parameter is relevant. But it is bad advice to try to extract RDSon from the other figure. The threshold spread is quite large for that part from 1V to 2.5V and the figure just gives you "typical values". That means if you are lucky and get a part with a threshold of 1V you probably can easily drive the gate with 3.3V, but if it has a threshold voltage of 2.5V the device just turns on a little and a tiny current trickle through it...

In conclusion: Check if the datasheet has an RDSon rating at or below 3.3V and also check the current condition of that RDSon rating. The channel pinches off when you try to drive too much current through it, so even if the RDSon is rated as VGS=3.3V, the resistance can shoot up when you try to drive more current through it. For this application you also don't need a power MOSFET. A small signal MOSFET is enough, but do oversize so it can do maybe 5A or more, since datasheet usually assume with the maximum current rating that you have a pretty good heat coupling to your PCB and that it remains at 25C during operation... Also BVDSS of 60V is also an overkill. That significantly increases your RDSon and decrease the current you can drive through it. With a 5V supply you can use a device with a BVDSS rating of 12V or 20V. That should be enough.

For example at nexperia.com is a parametric search, which lets you filter for BVDSS, VGSTH (threshold) and so on... The typical threshold can be as low as 0.6V if I remember that correctly and these devices do have RDSon ratings at 2.5V... I guess you need something like this:

https://assets.nexperia.com/documents/data-sheet/PMV16XN.pdf

| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

The gate of a Mosfet uses no current.

A Mosfet can be sensitive or not sensitive. The datasheet shows the range: The datasheet for your Mosfet says its on-resistance is 0.025 ohms maximum when its Vgs is 5V and says some of them conduct 0.25mA (almost nothing) when its Vgs is 2.5V. The datasheet shows a graph for a "typical" one drawing 1A when its Vgs is 3V.

So a typically sensitive one will work in your circuit but many will not work. You get whatever they have. So buy a few hundred and test them all, maybe you will find a sensitive one.

| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

Also consider that the 470uF cap is fully discharged by the lamp filament when in the OFF state and presents an extremely low impedance at turn ON. This aggravates the issue.

Lowering the value of the 1k resistor will help get the gate charged / turned ON faster. And yes, there IS a gate current (due to the gate capacitance) during turn ON and turn OFF...just as there is when charging or discharging any capacitor.

| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

I had a similar problem with a commercially made IR LED array. The array connects to the RPi GPIO to switch it on and off when using a camera.

The LEDs are driven by a BSP297 FET which, like the FET that you use, varies in its characteristics between devices. The array was probably designed around "typical" parameters and not worst case. Thus, some units will work and some not.

I solved the issue using this (kludge) circuit. The three diodes have a voltage drop across them of about 1.8V which shifts the voltage threshold seen by the FET upwards and, at the same time makes sure that the GPIO pin doesn't see more than three volts. The diodes are general purpose silicon, 1N4148 or similar. If the threshold is still not high enough for your FET try an extra diode.

schematic

simulate this circuit – Schematic created using CircuitLab

| improve this answer | |
\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.