0
\$\begingroup\$

I built several induction heaters based on the popular ZVS module available everywhere.

They all work fine with a 20mm coil diameter.

But the performance improve drastically with a 12mm coil diameter ; The problem is that the modules fail, but in a very peculiar way : When activated, 4 times out of 5, everything is OK, the control LED shines brightly, and the heated element gets to the desired temperature (around 220C) very rapidly. But 1 time out of 5, the LED seems to flicker very rapidly and faintly, and if the current is maintained, just as no heat is produced by the coil, one of the two MOSFET burns.

If, at that time (right when I see the LED flicker) the current is stopped, everything is fine, just press the switch again, and it works.

Note that I'm using heavy gauge wires and switches, just to eliminate those as a potential point of failure. I'm using 12V / 5A PSUs.

I tried shortening the coil wire to reduce the number of turns, but the problem persists.

How can I solve this problem, or turn around it? How can I at least make the ZVS module fail safely?

\$\endgroup\$
4
  • 3
    \$\begingroup\$ An ebay link with no circuit is asking for trouble. Post a proper circuit that matches what you are using. \$\endgroup\$
    – Andy aka
    Feb 10 '20 at 11:35
  • \$\begingroup\$ Thanks for your help ; But that's the thing, I never really get the same module everytime, and of course, the wiring diagram is not available freely ; So I was hoping for somebody to have experience with this kind of module, that could recognize my problem and point me in the right direction ; I'm really running out of ways to ask my question :| \$\endgroup\$
    – yPhil
    Feb 10 '20 at 11:40
  • 2
    \$\begingroup\$ It boils down to a repair question then and, without tech details nobody would really want to guess. \$\endgroup\$
    – Andy aka
    Feb 10 '20 at 11:45
  • 1
    \$\begingroup\$ What do you expect from this device? \$\endgroup\$ Feb 10 '20 at 12:43
1
\$\begingroup\$

OK, I got my answer from another place, where a user had the same problem : The PSU I used is not powerful enough ; and sure enough, I tried the same setup with a 12V 6A (Salcar) PSU, and it works : That is, when it does not, the module just does not start. It's quite counter-intuitive that I have to use more power to not fry the MOSFETs.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.