0
\$\begingroup\$

When I start a new STM32 project, I chose Nucleo F030R8 board, type in project name and click "Finish", the program downloads and unzips required firmware, but then I get the following error message:

"Code generation could not be done because necessary firmware package is missing. Not able to complete STM32Cube project." errormessage

I tried installing firmware manually using packs from https://www.st.com/en/embedded-software/stm32cubef0.html but I still get this message.

It happens on two PCs and with two different Nucleo boards.

I found a similar topic on ST forum, but their solution didn't work. Has anyone came across similar problems? How to solve it?

I'm literally just trying to start learning STM32 so excuse me if this issue is too trivial.

\$\endgroup\$
  • \$\begingroup\$ What version of CubeIDE? Have you tried latest or other versions? Did you read the errata for known issues? \$\endgroup\$ – Justme Feb 15 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.