0
\$\begingroup\$

I trying to use http get method on SIM800l (mcu for controling SIM800 is STM32F407VGT6). I can send SMS message or read all/specific SMS message but with http methods I'm in trouble(power supply is enough for SIM800l). I read so many forums, datasheets, blogs and still can't solve problem. My idea with SIM800l is to read context from some web-page. Here are my initialize steps:

AT+CFUN=1\r\n                         
// return AT+CFUN=1 OK

AT+SAPBR=3,1,\"CONTYPE\",\"GPRS\"\r\n 
// return AT+SAPBR=3,1,"CONTYPE","GPRS" OK

AT+SAPBR=3,1,\"APN\",\"internet\"\r\n
// return AT+SAPBR=3,1,"APN","internet" OK

AT+SAPBR=3,1,\"USER\",\"telenor\"\r\n
// return AT+SAPBR=3,1,"USER","telenor" OK

AT+SAPBR=3,1,\"PWD\",\"gprs\"\r\n
// return AT+SAPBR=3,1,"PWD","gprs" OK

AT+SAPBR=1,1\r\n
// return +SAPBR=1,1 OK

AT+SAPBR=2,1\r\n
// return AT+SAPBR=2,1
// +SAPBR=1,1,"10.60.122.39" OK

AT+HTTPINIT\r\n
// return AT+HTTPINIT OK

AT+HTTPPARA=\"CID\",1\r\n
// return AT+HTTPPARA="CID",1 OK

AT+HTTPPARA=\"URL\",\"www.google.rs\"\r\n
// return AT+HTTPPARA="URL","www.google.rs" OK

AT+HTTPACTION=0\r\n
// return AT+HTTPACTION=0 OK

AT+HTTPREAD\r\n
// return AT+HTTPREAD=0 OK

AT+HTTPTERM\r\n
// return +HTTPACTION: 0,200,14569
// AT+HTTPTERM OK

AT+SAPBR=0,1\r\n
// return  AT+SAPBR=0,1 OK

So again this is classic, most common initialize setup for SIM800l when we want to use HTTP methods. As we can see, SIM800l give me response with delay and when another response is expected. This is only happen in last steps. My question is why I got this response? Why I don't get +HTTPACTION: 0,200,14569 after I send AT+HTTPACTION=0. If I try with delays, result is same. And why MCU can't read anything when I call AT+HTTPREAD? SIM800l give this response: AT+HTTPREAD=0 OK but I expect some data from server to be there.

| improve this question | | | | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.