I recently bought a remote control toy for my son which included 2 2S battery packs, with a single SM-3P plug, and a corresponding USB charger as shown here.

enter image description here

Initially, the car worked fine, though within one or two uses (can't recall now), one of the packs simply stopped powering the car, even though the supplied charger seemed to charge the pack successfully.

Soon after, the other pack has done likewise.

I have confirmed the car works fine when I wire up another 2S LiPo pack to it using jumper leads, so it is clearly the supplied packs that are under question.

I applied a volt meter across the terminals of the batteries. What I found for both packs is making me question my sanity:

  • positive and negative terminals of the volt meter across corresponding battery terminals - 0v
  • positive (volt meter) to positive (battery), negative (volt meter) to center (blue) battery terminal - roughly 4.1v
  • positive (volt meter) to negative (battery), negative (volt meter) to center (blue) battery terminal - roughly 4.1v

suggesting the following internal wiring...


simulate this circuit – Schematic created using CircuitLab

This just raises so many questions in my head:

  1. How can a circuit like this provide 7.4V output?
  2. How did the car work out of the box and now exhibit this behaviour?
  3. Can Li-ion cells reverse charge somehow? If so though, why would the charger have caused this anyway?
  4. Why is my hair on fire?

I have not cut open the insulation to confirm the above assessment yet (it seems ludicrous!), as I don't have a good way of re-sealing it all up again and am hoping there is some logical explanation out there and a simple solution to the problem. Any suggestions or recommendations greatly appreciated!

Lastly, for the avoidance of doubt, the SM-3P battery connector in the car has only two pins, which connect to the red and black wires on the battery, as you would reasonably expect.

UPDATE: Just noted this post which suggests a possible explanation. It still seems very odd that this should happen to what should be two brand new batteries with only one or two cycles each, and both exhibiting an apparent full charge level in the reverse direction on the second cell.

UPDATE: Have cut away the insulation now. Here's what I found:

enter image description here

Also, I tried reading the voltage off the charger pins without the battery connected, but can't get a consistent result. It appears to oscillate quickly between about +3V and -3V, though difficult to be certain of those figures. My multimeter (Uni-T UT139C) doesn't update quite quickly enough.

UPDATE: Confirmed cells read normally when tested individually, per comment from Bruce. One reading 4.2v at present, the other reading 3.9v. (Oddly, I'm still getting 4.2v and 4.1v when reading across the plug pins... must be some function of the PCM causing this.) Voltage in series is 8.1v

Likely then that the PCM has malfunctioned somehow (in both batteries)? Perhaps the charger has caused some damage?

UPDATE 15-Apr-2020: So I finally received the replacement PCMs I ordered from AliExpress today. I am now ready check myself into an mental asylum. After switching the old module out for the one of the new modules, the behaviour is exactly the same. I even tried connecting the old and one of the other new modules to a separate pair of 18650 cells I had and got the same behaviour consistently. 0v across the power terminals of the PCM and voltage seemingly reversed when testing across the P- and BM (guessing this stands for Battery Middle?!) terminals of the module. Testing across the B- and BM terminals gives a reading as you would expect from testing the cell in isolation (that is, it isn't inverted!), though the reading is consistently around 0.1V or so off from the negative voltage reading gotten from P- and BM (similar to what I observed previously). Where do I go from here? How did this ever work? What am I doing wrong?

  • \$\begingroup\$ What is the voltage across the two outer pins (red/black), and of the two outer pins of the charger when plugged in to USB but not connected to the battery? "I have not cut open the insulation"" you should do this, and post photos of the internal battery wiring here. \$\endgroup\$ Feb 19, 2020 at 0:27
  • \$\begingroup\$ Thanks @BruceAbbott, have done so now. Voltage across the outer pins is 0v, per my first bullet point. \$\endgroup\$
    – John Rix
    Feb 19, 2020 at 0:57
  • 1
    \$\begingroup\$ It appear that the cells are in series and that you should get 4.1V across each individually (full charged) or 3.6V nominal and 8.2/7.2V across the pair. it APPEARS that one cell has reverse pilarity. - This "DOESN'T HAPPEN" with LiIon cells - but may with NimH/NiCd sort of sometimes. Cell in left photo with visible terminal by red lead should have +ve at that end and other cell should have -ve at this end. Is that what you measure ?(not according to your text). | Summat bad. \$\endgroup\$
    – Russell McMahon
    Feb 19, 2020 at 1:30
  • \$\begingroup\$ Now that the battery wrapping is off we see that it has a PCM (Protection Circuit Module). If any cell is abnormal this will probably have turned off and disconnected the negative side. Please measure the voltage across each individual cell (positive end has white ring) and the voltage of both in series (ie. the ends shown in the photo). \$\endgroup\$ Feb 19, 2020 at 6:29
  • \$\begingroup\$ Thanks guys. Have added an update there. Should have thought to check the individual cells myself last night after taking the wrapping off! \$\endgroup\$
    – John Rix
    Feb 19, 2020 at 11:39

1 Answer 1


My 2 cents coz had the same problem with my grandson's rc. The stock battery died after 4-5 charges. Simply, get new 2 pieces 18650 battery. Unwrap the stock battery pack, unsolder the wirings with the balance connector. . Use that same wire exactly on the new batteries. Bingo, you just save couple of dollars for stock replacement battery! Test using the balance connector, will read cell 1, cell 2 and total charge.

  • \$\begingroup\$ In my case, the individual cells were still fine. I never solved this one and simply could not make sense of what the PCMs were doing. I eventually bought a replacement battery of the correct type for the car from AliExpress. Even with that, the car ran a couple of times and then the individual motor drivers on the main board burnt out, one by one until the car would not move at all. Can't find a replacement board for the car. Pure waste of money and so annoyed about the whole affair. :-( \$\endgroup\$
    – John Rix
    Mar 31, 2021 at 11:23
  • \$\begingroup\$ Too much Chinesium produces a low cost (cheap stuff) but poor performance and poor endurance. I have a video of an 18650 battery from "over there" cut open and revealing that it is mostly full of rice flour. \$\endgroup\$
    – Audioguru
    Sep 30, 2022 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.