1
\$\begingroup\$

I've purchased this USB blaster: https://www.amazon.com/dp/B07F5H5LPZ/

Because I have this Ep2c5/ep2c8 dev board, I've been following this video to begin my work with FPGAs: https://www.youtube.com/watch?v=le6Jo5DpLao

Here is my problem. After connecting the USB Blaster to my Win7 computer for the first time and installing the driver from altera\11.1sp2\quartus\drivers, the USB Blaster shows up in the control panel as "USB-Blaster(Altera)" but Quartus II doesn't show it in the Programmer's Hardware Setup page.

In troubleshooting, I also tried installing the same version of Quartus II and the USB blaster on my Win10 laptop, but the driver isn't signed for win10 so I dropped that approach. Back on the Win7 computer I tried using the command prompt to open altera\11.2sp2\quartus\bin\jtagconfig.exe and saw it read out the message "No JTAG hardware available".

Is there something obvious that I'm doing wrong here? Do I have a bunk USB Blaster? Do I have the wrong hardware or software altogether?

\$\endgroup\$

7 Answers 7

1
\$\begingroup\$

I found out while using Quartus Standard, the answer is to disconnect other USB devices and the blaster is seen again by Quartus

\$\endgroup\$
1
\$\begingroup\$

[Win10]

I had this problem with the Blaster II. It would show up as "Altera USB-Blaster II (Unconfigured)" even after I installed the drivers.

On Quartus Pro 20.4, the chip programmer GUI would not see this device. I solved this by running the chip programmer GUI as administrator. Once the program launched, I could hear the typical USB connect/disconnect ding-dong sound effects from Windows. Then the device showed up in the programmer and it worked fine. In device manager, its new name was "Altera USB-Blaster II (JTAG interface)". After that, I didn't have to run the programmer as administrator to connect.

\$\endgroup\$
1
\$\begingroup\$

I just encountered this problem on Windows 11 64-bit. I ran the command "C:\intelFPGA_lite\22.1std\quartus\bin64>quartus_pgm.exe -l", which should list available programmers, and it said "No JTAG hardware available". I tried solutions listed here. None worked. The registry key suggested isn't there on W11 either.

But this worked for me, following the W10 guide: https://www.terasic.com.tw/wiki/Altera_USB_Blaster_Driver_Installation_Instructions

Let me write it as well, in case the wiki is removed:

Plug the USB-Blaster into your PC.

Open the Device and Printers (Control Panel | Devices and Printers).

Under Unspecified, USB Blaster should be listed. Right mouse click on this and then select Properties.

Select the Hardware tab and select Properties. A new window should pop up with the General tab already selected. Select Change Settings. Again a new window should pop up with the General tab already selected. Select Update. Select

Browse my computer for driver software.

Find \quartus\drivers\ (Note 1: Your altera file is located at the location you selected when you first installed quartus. The location listed in this document is the default location) (Note 2: Stop at the drivers folder, i.e., do NOT go deeper by opening a folder within the drivers folder. This is important.) Select OK.

Make sure the proper path was selected then select Next. If the Windows security window pops up Check the Always trust software from “Altera Corporation”box and select Install.

I don't think I had to restart, but you might have to. Try running C:\intelFPGA_lite\22.1std\quartus\bin64>quartus_pgm.exe -l again, and see if the device is listed. It was for me "1) USB-Blaster [USB-0]".

Hope it helps someone else.

\$\endgroup\$
1
\$\begingroup\$

Although this thread is quite old I recently had the same issue and none of the suggestions here worked for me.

However, after much frustration I did find a solution that works for me.

I have an FTDI based UART<->USB cable which I use to communicate with the board I am working on, I found that if I have the associated COM port open in my terminal application (SecureCRT, in my case) the USB-Blaster does NOT show up in Quartus. If I simply close the COM port the Blaster is once again available in Quartus.

\$\endgroup\$
0
\$\begingroup\$

Installing Quartus ii 13sp1 solved the issue. I got by using the newer software+newer driver.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Sometimes one line answers are acceptable, this is what fixed the issue and it works. \$\endgroup\$
    – Voltage Spike
    Sep 26, 2020 at 16:26
0
\$\begingroup\$

Try this solution:

  1. Open regedit.exe
  2. Delete the whole \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses\{219d0508-57a8-4ff5-97a1-bd86587c6c7e} key
  3. Reconnect USB Blaster
  4. Press "Hardware Setup" button in Quartus Programmer.
  5. If there is USB Blaster select it and enjoy. If it still not detected reboot your PC.
\$\endgroup\$
0
\$\begingroup\$

Finally found solution, For de10 lite https://github.com/sudhamshu091/USB-Blaster-Driver-for-DE10-lite and de10 nano and de1 soc https://github.com/sudhamshu091/USB-Blaster-ii-Driver-for-DE10-Nano

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Do you think you could expand this answer as to what the solution is? \$\endgroup\$
    – Voltage Spike
    Mar 18, 2022 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.