1
\$\begingroup\$

Note- I'm a programmer, not an electrician.

I'm replicating the circuit found here: https://www.youtube.com/watch?v=4ObzEft2R_g&t=04m50s (circuit @ 4:50)

enter image description here

I've soldered two identical PCBs, and when hooked up to a speaker, both worked great! However, I was testing the functionality by loosely touching the speaker input to the output of the 1000uF capacitor on one of the boards (and it was working!), when my finger slipped and I think the speaker input wire grazed some other component on the PCB.

I heard a small pop in the speaker, and when I hooked it back up, it didn't work anymore (silence).

I tested the speaker with the other PCB, and it's still working fine.

What might be wrong with my circuit? How can I debug this without essentially just re-soldering it all from scratch?

I already swapped out the LM386 with a fresh one, and it still doesn't work (I guess there's a chance I grabbed a dud LM386?). Visually, the chip/capacitors/resistors all look identical to the functional PCB.

I have a multimeter, and have access to an oscilloscope. I just don't know what to look for.

Where can I start?

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Start by posting the circuit diagram in your question. \$\endgroup\$
    – JRE
    Feb 28 '20 at 1:02
  • \$\begingroup\$ I did- youtube.com/watch?v=4ObzEft2R_g&t=04m50s \$\endgroup\$
    – Phildo
    Feb 28 '20 at 1:08
  • \$\begingroup\$ No, you didn't. That's a link to a video. Post a drawing of your circuit. \$\endgroup\$
    – JRE
    Feb 28 '20 at 1:15
3
\$\begingroup\$

Since the speaker works, and you've already tried replacing the LM386, there's not much left.

I'd start with the battery. A short circuit could do horrible things to a 9V transistor battery.

Next would be to remove the 100µF capacitor connected to pin 7.

After that, remove the 100µF capacitor connected to pin 6.

If it still doesn't work, remove and replace the 1000µF capacitor.

You could try trouble shooting by looking at the output of the amplifier. Disconnect the speaker, and connect the oscilloscope probe to pin 5 of the LM386. If you see a signal there that follows the input, then that big capacitor is probably bad.

The circuit is simple, and there's not really much that can break. The LM386 itself is pretty robust and simple - I can't imagine you've destroyed it.


Typical horrible YouTube video schematic. No designators for the parts, so we have to try to describe which parts are being discussed instead of calling them by name.

Also, faded almost to illegibility. I had to hit it with the GIMP and fix the contrast to be able to read it at all.

\$\endgroup\$
1
  • \$\begingroup\$ thanks for help- turns out I had just grabbed a dud LM386 replacement. swapped it again and it's working. \$\endgroup\$
    – Phildo
    Feb 28 '20 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.