0
\$\begingroup\$

I am having trouble actuating this relay I bought off Amazon. I have been successful actuating the relay but am having issues wiring up a LED to simply turn on and off. My setup looks very similar to this (see attached) with two modifications, running it off an Arduino Uno and wiring up the JDVcc and GND to a separate 5v power source(set of pins that normally have the jumpers attached). Here is the relay I bought: https://www.amazon.com/gp/product/B072BY3KJF/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

LED on the breadboard is not illuminating at all, however the relay is actuating and making a click. The status led built into the relay does light up accordingly, indicating I have an issue with the high voltage/current side of my wiring. Any help would be greatly appreciated! Thanks. -MikeRelay and Arduino Setup

\$\endgroup\$
  • \$\begingroup\$ Can you post a high resolution photo? That one would have been great in 1995. \$\endgroup\$ – Transistor Mar 21 at 22:34
  • \$\begingroup\$ from what I can see of this tiny photo, it looks like your orange wire on the red LED isn't connected to the right part of the breadboard? Give us a bigger photo and we should be able to help more. \$\endgroup\$ – Hearth Mar 21 at 22:38
  • \$\begingroup\$ Also note that that is not the relay you bought that you linked, that's the relay module you bought. The word module is important. \$\endgroup\$ – Hearth Mar 21 at 22:38
  • \$\begingroup\$ Disconnect the load i.e. Leds, and only connect the common pin to 5V. Then measure you NC and NO. One will read 5V and the other will read 0V. Then probe only one of the NC or NO and activate the relay via the IN1 pin using the arduino you should then see a change in the state of the NC or NO. \$\endgroup\$ – Joey Mar 21 at 22:48
0
\$\begingroup\$

I have figured out my problem. Thank you guys to responding to my post. I noticed that my LED was hooked up with the opposite polarity causing it not to illuminate. There are actually several of these knock off relays on Amazon, where I purchased it. My original does not actually match what I received which is definitely not cool. If any of you Google DataStore, I have a separate post that I could use help on as well, related to this project.

I am also not getting email notifications on comments/ replies on posts but would appreciate advice on how to turn these on. -Thank you!

| improve this answer | |
\$\endgroup\$
  • 1
    \$\begingroup\$ It's still a module and not just a relay. SE has no email notifications. You just check in and check your in-tray. \$\endgroup\$ – Transistor May 29 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.