0
\$\begingroup\$

I have been doing nasty things with my proteus, and right now, I have a schematics that's well defined, but the components are not present in the PCB layout (therefore, I can't place them, as I can't pick them in the "empty" list).

Does someone knows how to force the update the components of the PCB based on the schematics?

The other solution would be to redo everything from scratches, which don't motivates me a lot...

enter image description here

There should be a list of components in the field marked with the interrogation marks "?".

(For those curious, the diagram is a way to digitally control a PWM for motors with a raspberry PI ^^, )

I'll continue to search, but I already feel like having gone through every menu button...

Thank's by advance !

\$\endgroup\$
0
\$\begingroup\$

I haven't used Proteus, but in other ECAD packages, you have to define PCB footprints in the schematic symbols. Then the footprints will be listed in the netlist passed to the PCB program.

Usually, you would define a default footprint when you create the schematic symbol, but you should also be able to set the footprint after placing the component on the schematic.

\$\endgroup\$
2
  • \$\begingroup\$ In proteus, normally, the components are loaded automatically to the PCB desing tab, but I deletted everything, so I'm searching to put them back automatically... \$\endgroup\$ – zepeu Apr 2 '20 at 9:19
  • \$\begingroup\$ You should be able to re-load the netlist, which will restore the components you deleted. \$\endgroup\$ – Peter Bennett Apr 2 '20 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.