2
\$\begingroup\$

I've tried connecting a small DC Motor I got in a starter kit for a Raspberry Pi Model 4. I believe it is a 1 - 6V.

I used this circuit diagram:

enter image description here

This worked, but subsequent runs seem to have no effect. My motor does not run anymore. I am curious if anyone has any ideas regarding this. Did I overload the motor? Is the motor just faulty?

I also don't want to damage my Pi, and everything else seems to be working properly.

Any insights would be appreciated.

The motor is part of this kit.

| improve this question | | | | |
\$\endgroup\$
  • 3
    \$\begingroup\$ Try to power the motor directly from PSU then you will see if it's faulty. Use you imagination. \$\endgroup\$ – Marko Buršič Apr 3 at 22:24
  • \$\begingroup\$ What are the motor specs? Do you have a multimeter? \$\endgroup\$ – Bruce Abbott Apr 4 at 0:40
4
\$\begingroup\$

Maybe the motor overloaded and burned out the transistor.

| improve this answer | | | | |
\$\endgroup\$
3
\$\begingroup\$

As mentioned above by @Marko Buršič you can just connect the motor to the supply to check if it is working.

If this is the case then I would try driving the circuit off another GPIO pin to see if that works. The motor is a reactive load which is why there is a diode (IN4148) to protect the pi against back EMF. If the diode has failed or the wiring is faulty you may damage the GPIO output in question.

| improve this answer | | | | |
\$\endgroup\$
  • \$\begingroup\$ I went ahead and connected the motor directly to the power source, and it does seem to work. I would like to try your suggestion, but am worried about damaging another GPIO pin (if that was in fact what I did). So essentially, you believe the diode failed/was wired incorrectly- and resulted in a damaged GPIO from back EMF? \$\endgroup\$ – find_all Apr 9 at 0:17
  • \$\begingroup\$ Since you have ruled out the motor as the problem I would take a look at both the GPIO pin or the transistor. It might be hard to check the GPIO as the fault might not be clear-cut (e.g. the GPIO driver circuitry might be damaged affecting other pins) but I would try the following. Get a DVM and try driving 2 or 3 of the GPIO pins (from a program) high and low including the GPIO pin you think has failed, check the output voltages and publish them here. You may find this raspberrypi.org/forums/viewtopic.php?t=239208 helpful. \$\endgroup\$ – mhaselup Apr 9 at 2:03
  • \$\begingroup\$ So I've done a number of things thus far (since testing the motor). Firstly, I got a multimeter and tested both the diode and the transistor, both return a value to my multimeter (which means they are working?). I also tested the GPIO pin in question, and it was successful in lighting an LED. Is this a sufficient test for checking the state of the GPIO pin or should I use the multimeter (which is what I believe you are suggesting)? I am somewhat at a loss at this point. I can provide pictures of exactly how I wired it if that would help, as well as my code. \$\endgroup\$ – find_all Apr 10 at 8:45
  • \$\begingroup\$ You could take the original circuit and replace the motor with an LED in series with a 1k resistor. If the LED lights you'll have tested everything without the motor. \$\endgroup\$ – mhaselup Apr 10 at 9:23
  • \$\begingroup\$ Thank you. When connecting an LED it does seem to work, which actually just makes me even more confused. Both the motor and the circuit seem to work independently, but not together. The only clue is that as soon as I booted up the Pi, the light was on, and it oscillated when the code relating to the motor operation was triggered. Is this correct? How could both the motor and the circuit work independently but not together, there must be something stark I'm missing here. \$\endgroup\$ – find_all Apr 10 at 9:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.