-5
\$\begingroup\$

I have implemented a class AB amplifier. The schematics are below.

My class AB amplifier schematics

As you can see, my \$V_{cc}\$ is only 1V. How come I can still suppy 2.8 amp to the 4 ohm speaker/load? Is it a bug in MultiSim, or did the input signal (16V pk AC) made its way to the speaker? As far as I know, the voltage output in the load cannot exceed \$V_{cc}\$.

Both transistor appear to be in good placement/direction, but I've seen other configurations in which the transistors are reverted.

Here is a link to my schematic.

Safety question: Is it ok for my 4 ohm speaker pass the whopping 2.8 amps? Is it common for power amplifiers to do that?

\$\endgroup\$
  • 2
    \$\begingroup\$ Your text says the load is 8 ohms but your schematic says 4. Your supply rail is a fraction of the specified input swing. No negative feedback, but positive feedback. This monstrosity will both clip and oscillate. I suggest you go back to the books. Not a real question. \$\endgroup\$ – user207421 Nov 20 '12 at 22:25
  • \$\begingroup\$ edited. 8 ohms was a typo. sorry \$\endgroup\$ – WantIt Nov 21 '12 at 10:45
1
\$\begingroup\$

That will not work. You cannot drive the the transistors above the collector voltage otherwise the Vbc becomes forward biased.

\$\endgroup\$
1
\$\begingroup\$

You appear to have connected the output directly to the input. Even if that is corrected, the input signal will go to the load through the base-emitter junctions of the transistors.

A class AB output stage will have a voltage gain of alpha, which is slightly less than 1.

I'm not sure what you're trying to accomplish by driving your circuit with 16V.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.