I recently had a question about the layout for an LM2678-ADJ switching regulator. Since, I have built the circuit and layout as follows:

enter image description here enter image description here

So far, I have only had moderate success with the circuit. With an input voltage of 30V and up to 6A available, everything works well (at least, output voltage constant), up to a current draw of up to about 2.5A. Above that, the voltage drops dramatically and the diode starts getting hot(ter).

The following waveforms were taken at different current draws, with the rheostat set to produce 12V out: Yellow is measured across diode D1, and blue across capacitor C3 at the output on the right.

Current Draw: 0.1A


Current Draw: 2.4A

enter image description here

Current Draw: 2.5A

enter image description here

Current Draw: 3.0A

enter image description here

Aside from the slight ringing at 0.1A, it seems to normalize out to a square waveform by about 0.15A and everything looks well to about 2.4A.

However, at around 2.5A, where the voltage drop occurs, there seem to be "misses" in the waveform, and going further in 0.1A increments to 3.0A, the waveform only shows "misses".

I have read on other threads that the inductor needs to be large and have low resistance.

L1 is a torodial 47 µH with a DCR max = 13.5 mΩ and rated 10A.

D1 is an STPSC10H065D 10A Schottky Diode

I have tried a small ceramic across D1's terminals without success. Also, this thread says ringing should be checked, but there doesn't seem to be any in the above output (except under low/no load conditions).

So finally, my question is very basic: What is causing this, and how can it be fixed?

The datasheets for the components are here:

L1 Datasheet

D1 Datasheet

Regulator Datasheet

EDIT 2020-05-22

I have measured the input voltage, and am seeing some nasty feedback/ringing that I think is causing my issue: The blue is the input measured across Input and GND pins on the regulator (AC coupling), and yellow measured on Switch_Output pin (DC coupling)

0.2A load enter image description here

2.0A load; distortion worse enter image description here

3.0A load; everything is crazy enter image description here

I have tried:

  • Adding more input capacitance (to lower RMS)

  • Adding more output capacitance (to lower RMS)

  • Trying different Schottky diode

  • Different inductors as suggested and accepted as answer at first, one 3A 47uH for 255kHz switching regulators, and a 68uH stolen from a DC-DC boost converter. There was no measurable effect.

  • Resoldering on another prototype board with different layout in case ground plane or whatever on the board is causing this. Effect was about 0.3A more load before breakdown.

  • \$\begingroup\$ Schematic and part numbers plus data sheet links are usually the most important things to post first. \$\endgroup\$
    – Andy aka
    Commented May 16, 2020 at 11:51
  • 1
    \$\begingroup\$ The waveform for the low load is identical to the discontinuous mode (which is to be expected) switching diagram in the datasheet; see figure 13. \$\endgroup\$ Commented May 16, 2020 at 11:52
  • \$\begingroup\$ @Andyaka Added the datasheet links and schematic from other post \$\endgroup\$
    – namezero
    Commented May 16, 2020 at 11:56
  • \$\begingroup\$ @PeterSmith Yes, that looks to be ok then. It's my first time trying a switching regulator. The datasheet has a lot of things in it that I am not fully familar with yet :} \$\endgroup\$
    – namezero
    Commented May 16, 2020 at 11:57
  • \$\begingroup\$ The inductor data sheet you linked does not state the rated current - better link/DS is needed or don't use that part. \$\endgroup\$
    – Andy aka
    Commented May 16, 2020 at 12:04

2 Answers 2


The LM2678 operates at approximately 260 kHz and this means that you must choose an inductor with a lot of care and attention to detail. The inductor you have chosen is \$\color{red}{\text{not suitable}}\$ from the information that is available. Having dug a little deeper it seems that its core is iron dust/powder and this is likely to have significant eddy current losses at 260 kHz. What mouser says about this 47 uH: -

enter image description here

Highlighted in red boxes are the things that sounds alarms with me.

I'm not ruling out anything else but the inductor is a poor choice.

  • \$\begingroup\$ I have also noted that the volt microsecond rating is not stated, but it is a critical part of the design procedure. \$\endgroup\$ Commented May 16, 2020 at 12:24
  • \$\begingroup\$ @PeterSmith I doubt that not having this stated is the problem, it's more basic than that. \$\endgroup\$
    – Andy aka
    Commented May 16, 2020 at 12:53
  • 1
    \$\begingroup\$ Choose a ferrite core material preferably made from a material that has low losses at 300 kHz. 3F3 material made by Ferroxcube springs to mind if you want to use that as a techy reference but, in truth, all the major ferrite makers have a near equivalent. \$\endgroup\$
    – Andy aka
    Commented May 16, 2020 at 15:24
  • 1
    \$\begingroup\$ OK it was failing at 3 amps and is now failing at 4.5 amps? \$\endgroup\$
    – Andy aka
    Commented May 24, 2020 at 9:08
  • 1
    \$\begingroup\$ OK, sometimes you gotta go down a few paths to get to the solution. I've learnt from the past that if the supplier specifies this or that then it's just not worth trying to find an alternative. The problem with the diode is that it had a really quite large forward volt drop. \$\endgroup\$
    – Andy aka
    Commented May 26, 2020 at 8:03

I will leave the original answer intact, but would like to add something about the root cause.

After despairing in many troubleshooting sessions and trying different inductors, diodes, capacitors (including components in the TI datasheet) and a different layout on prototyping board I have finally found the root cause, and can mitigate for issue.

During troubleshooting, I inadvertently measured the ringing against GND rather than VIN. When I realized that the ringing occurred between the GND input terminal and the GND pin on the LM2678 as well as the diode, and virtually any other point on the board I measured, I tried to track down the EMF source.

It seems like the GND plane under the inductor was exposed to enough EMF to cause this issue. After cutting the ground under the inductor to disconnect it, the ringing stayed roughly constant:

enter image description here

  • VIN = 10V; VOUT=5V; Input Ripple = 300mv

  • VIN = 30V; VOUT=5V; Input Ripple = 500mv

  • VIN = 40V; VOUT=5V; Input Ripple = 700mv

While I'm not entirely happy with (and unsure of how to improve) the 700mv at 40V in, everything runs stable at maximum current of 5A.

  • 1
    \$\begingroup\$ Oops yeah. You need to remove ground underneath any of the inductor turns that are close to the surface of the PCB. Very large eddy currents will be induced in copper close to those turns. Glad you found it; I was beginning to suspect fake components. \$\endgroup\$
    – Andy aka
    Commented May 28, 2020 at 17:26
  • 1
    \$\begingroup\$ I'll try to move the inductor away from power planes in real life! \$\endgroup\$
    – namezero
    Commented May 28, 2020 at 17:51
  • \$\begingroup\$ So maybe the rest is induced via ground on the heatsink or diode. I'll attempt to shield this somehow. Thanks for all your patience! \$\endgroup\$
    – namezero
    Commented May 28, 2020 at 18:14
  • \$\begingroup\$ It'll be screwing with the inductor that's for sure. \$\endgroup\$
    – Andy aka
    Commented May 28, 2020 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.