0
\$\begingroup\$

I'm relatively new to electronics (as a mechanical engineer, I had circuits courses... those were years ago now, but I'm not COMPLETELY ignorant), and wanted to take some of this quarantine time to learn more about a hobby I've meant to look into for years. I've had some issues with the experiments using a 2N6027 PUT in the Make: Electronics 2nd Edition book, specifically experiments 11 and 14. When experiment 11 didn't work; the pulsing signal that was supposed to be coming from the cathode of the PUT to blink an LED on and off in step 1 of experiment 11 wasn't working, instead just sending a constant signal and keeping the LED always on.

I thought that maybe it was something with the voltage divider across the gate pin of the PUT, since I don't have the exact 15k and 27k resistors that the experiment calls for, and used a few resistors in series to reach the proper voltage. I have 15k and 27k resistors on order now and have moved on in the book, to come back when I have those resistors.

Now, in experiment 14, there is another experiment with the same 2N6027 PUT. This time the resistors on either side of the gate pin are 1k resistors, so since I had 1k resistors I was hoping that this time the experiment would work, but... same result. Constantly on LED, no blinking/pulsing activity at all. Below are pictures of the schematic for the experiment in the book and of my breadboard, circuit is being powered with 6V as being recommended in the book.

SchematicBreadboard

Since I didn't have a 33k resistor, I'm using 3 resistors in series as you can see, total resistance is ~33.3k, I don't think that the extra 300 should be a problem, but I am new to this so let me know if there's any reason that would cause a problem. The other resistors are all within 50 of 1k, I've measured each one to verify this. I've tried multiple 2N6027s and all of them give the same result: LED comes on and stays one, while capacitor is charged for the duration, never discharging.

If anyone can see anything that looks wrong or has any troubleshooting ideas, please let me know... the fact that I can't get two separate PUT circuits to work leads me to believe that I'm just really doing something wrong. I'm more or less at the end of my rope with these, I've been screwing around with these PUT circuits for hours now and haven't been able to get the proper results... this seems like it SHOULD be simple, but I just can't figure it out. Thanks in advance!

\$\endgroup\$
6
  • \$\begingroup\$ Please read this. I discuss the 2N6027 there, is some more detail. \$\endgroup\$
    – jonk
    Commented May 18, 2020 at 16:20
  • \$\begingroup\$ I suggest you increase the value of R1 to say 360k Ohms (ball park figure). I don't think the PUT is switching off because the anode current is not dropping below the valley current specification. If you do this you'll need to reduce the size of C1 to say 10uF to keep a reasonable time constant (flash rate). The circuit should take a few seconds to start oscillating after power up as C1 charges up. \$\endgroup\$
    – user173271
    Commented May 18, 2020 at 19:56
  • \$\begingroup\$ @jonk Thank you for the post! A lot of detail there, still trying to go through and parse all of it... If I get it, seems as though the PUT is switching on then never switches off because it doesn't reach the valley current? (@James, I see you're saying the same thing!) I increased the R1 resistance and changed the capacitance as per James's suggestion... no change. LED is on from the moment power is connected to the circuit and stays on. Voltage still never drops across the capacitor. Any other thoughts? Do I just have things connected wrong? Could all the PUTs I tried be bad? \$\endgroup\$ Commented May 19, 2020 at 8:40
  • \$\begingroup\$ @PlunderBunny Yes, it actually must go below the valley current. If not, then it just moves right on the curve and stays there. The datasheet provides a minimum value for the valley current at a few different specifications. You need to find one closest to your situation and, perhaps, divide that by 3 to be sure. Note that this increases when the gate Thevenin resistance is lower, so another way is to lower that gate Thevenin resistance to raise the valley current upwards. Either way, you need to sink well below it to be sure. \$\endgroup\$
    – jonk
    Commented May 20, 2020 at 6:00
  • \$\begingroup\$ @jonk Thank you for the advice! I'll try lowering the gate Thevenin resistance and see whether I'll be able to get below the valley current that way. Is there an equation defining the valley current as a function of RG & VS? \$\endgroup\$ Commented May 20, 2020 at 6:15

1 Answer 1

2
\$\begingroup\$

I'm unconvinced by all the suggestions! The resistor values are not crucial, and the capacitor value can vary significantly. If the transistor isn't going through its negative phase and reaching the valley point, I'm betting the transistor is dead. Have you, by any chance, tested it?

I can't entirely check the circuit, because some leads are partially hidden. Would really be helpful to trim the leads and making everything easier to see.

The first edition of Make: Electronics was published almost 11 years ago, and I haven't received reports of this problem, so I think it has to be a component issue.

PS. Thanks for reading my book, and sorry you have this problem.

\$\endgroup\$
1
  • \$\begingroup\$ Welcome to SE.EE! It's nice to hear from the actual author... \$\endgroup\$ Commented Dec 23, 2020 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.