2
\$\begingroup\$

I want to control a relay RSB1A120BDS that works on 24V DC using my Arduino. But, my power source that I use for other parts is 41V AC connected to a bridge rectifier. So my idea was to put a resistor in series with the relay coil to get the right voltage. This is a bit my setup:

schematic

simulate this circuit – Schematic created using CircuitLab

The transistor is a TIP 120 STM NPN-Darlington TO-220 60V 5A 65W. (I know now MOSFETs are better for switching, but I didn't know that when I bought the transistors) I added a 220Ω resistor, because I read somewhere that this is necessary to limit current. I measure 3.27 V over R2 and 1.37 V between the base and the emitter. So we have 3.27 / 220 * 1000 = 15 mA base current.

The datasheet says the average resistance of the relay coil is 1440 ohm and the rated operational voltage is between 19.2 V and 26.4 V. So then by using a resistor of 1 kΩ, the voltage over the relay coil should be 41 * 1440 / (1440 + 1000) = 24 and that should be alright.

The flyback diode is a 1N4001 50V 1A. It removed it and measured it with my multimeter, and it seems to be working. (low resistance one way, very high resistance the other way)

However, it didn't work. When I turn the transistor on, sometimes I measure 23.7 V over the relay coil, but most of the time I measure 0 V, and all 41 V are over R1. So maybe the relay coil is short circuited. I also hear a sound sometimes while I'm working with the multi meter, I think the realy is turning on and off. I thought maybe the issue is that I use pulsed DC instead of normal DC, and the peak voltage of 24 * sqrt(2) = 34 is too high. But this answer says that shouldn't be a problem.

A thing is that 26.4 / 19.2 = 1.375 < 1.4 = sqrt(2). So I can never pick a resistor R1 to keep both the peak voltage and the RMS within the rated operational voltage limits, but almost though.

The relay makes a sound when I touch it with scissors. See this video.

When I try the simpler circuit below (same diode and relay, different but same type resistor), it does work as expected. No noise when I touch it with the scissors.

schematic

simulate this circuit

What is the problem here?

\$\endgroup\$
4
  • \$\begingroup\$ Two questions: 1) Does your circuit have a filtering cap after the rectifier (I'm asking this because you didn't show the full schematic)? 2) Are you sure that the flyback diode is not broken? (If it is broken then most likely it's shorted. So it's normal you see the full bus voltage across the 1k resistor.) \$\endgroup\$ – Rohat Kılıç May 19 '20 at 21:18
  • \$\begingroup\$ Or is the diode connected backwards? \$\endgroup\$ – Transistor May 19 '20 at 21:40
  • \$\begingroup\$ @RohatKılıç 1) No, it doesn't 2) Yes, because sometimes I do measure 23.7 V over the relay coil, and that wouldn't happen if the diode was broken. For the same reason it is also not connected backwards \$\endgroup\$ – Paul May 20 '20 at 10:40
  • \$\begingroup\$ Are you sure that the relay and the diode are not damaged? Which diode is this, could you try another piece? Did you tested this relay out of this circuit, switching it on using just the plain pulsed AC? \$\endgroup\$ – mguima May 26 '20 at 19:20
1
\$\begingroup\$

Your problem may be caused by any of the following:

  1. The transistor not being driven to saturation
  2. The surge current, at the point of relay actuation, causing a higher voltage drop across the resistor
  3. A loose connection.

This simpler circuit, not requiring dropping of voltage to the extent of 35V, may be tried out.

enter image description here

\$\endgroup\$
5
  • \$\begingroup\$ I did some measurements and updated the schematics to see if 1 is the problem. I calculated 15 mA base current. I don't really understand 2. The higher voltage drop across R1 is only for very short time, right? If eventually the voltage over the coil is 24 V, shouldn't it be alright? \$\endgroup\$ – Paul May 26 '20 at 15:12
  • \$\begingroup\$ Hi Paul, Does the relay operate when 24V is directly applied to its coil? \$\endgroup\$ – vu2nan May 26 '20 at 18:25
  • 1
    \$\begingroup\$ Solved it! I replaced resistor R1 and the it worked. So I think it was simply a soldering problem. \$\endgroup\$ – Paul Jun 5 '20 at 14:27
  • 1
    \$\begingroup\$ I'm glad you could solve your problem, Paul! \$\endgroup\$ – vu2nan Jun 5 '20 at 14:52
  • \$\begingroup\$ Thank you, Paul. \$\endgroup\$ – vu2nan Jun 22 '20 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.