0
\$\begingroup\$

I have found some Arduino tutorials where the voltage regulator died on board:

https://www.instructables.com/id/Fix-a-fried-Arduino-Mega/

However this is not the case for my Arduino Mega 2560.

The Arduino was powered through the 5V pin along with bunch of other sensors. In the meantime it was connected via USB to my laptop sending data through the serial.

Stupid mistake having my multimeter in amp measurement mode I shorted out the 5V line not even on the Ardu but on a sensor but that effectively shorted it for all of them.

After this surprisingly the Arduino perfectly worked kept running the code over restart however I can no longer use the USB port anymore, it does not even show up on the computer like it would not be plugged in.

What I tried:

  • I tried from both 12V adapter and powering the Arduino through USB (this works fine, I can measure 5V on the V+ in both cases).

  • I tried it on different laptops. No change.

Did anyone run into similar issue? If so is there any way to fix it?

Thanks

\$\endgroup\$
1
  • 4
    \$\begingroup\$ You been a member here for 4 years and asked several earlier questions all of which appear to have reasonable answers. Have you ever noticed that many questions get formally accepted (as indicated by a green tick) and, in doing so that closes down the question and, gives anyone coming along to read it some time later, a degree of belief in the answer being correct. If all your questions have unsatisfactory answers then I would understand why you haven't formally accepted any but, here you are today asking a new question so you must have gained some benefit in those answers going back to 2017. \$\endgroup\$
    – Andy aka
    May 29, 2020 at 17:12

1 Answer 1

1
\$\begingroup\$

If you're arduino still runs but isn't able to be identified at all over USB, you probably fried the microcontroller that handles the UART-USB conversion.

Easy fix would be to bypass that chip (since it's not working anymore) by using an external UART-USB converter. You could use this TTL-232R-5V cable and plug it directly from your computer to the UART pins of the arduino.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.