2
\$\begingroup\$

Image of circuit, the i/o pins also have jumper wires that I connect to VSS/Ground for inputting dataI have a 28c256-25 EEPROM that I have created a breadboard circuit to program. The datasheet says after the address is set and the data is put on the I/O pins, a low pulse on /WE while /OE and /CE are tied high should write that data into the provided address.

I have tried (using an RC circuit) giving a 33 nanosecond, 100 nanosecond, and 500 nanosecond negative pulse on /WE, but I could not get the data on the I/O pins to get written into memory. Here is the datasheet: https://www.jameco.com/Jameco/Products/ProdDS/74878XICOR.pdf There is a short description of the Write cycle on page 4 and a timing diagram on page 14.Am I supposed to send the data on the I/O pins during or after the /WE pulse or something? What am I doing wrong?

\$\endgroup\$
  • 3
    \$\begingroup\$ A schematic would go a long way towards helping us solve this. \$\endgroup\$ – Adam Lawrence Jun 9 at 20:46
  • \$\begingroup\$ I have added a schematic. It excludes the jumper wires that I would have on the breadboard on the I/O pins that I plug to VSS/Ground to pick what data I want to write. \$\endgroup\$ – Yigit_Yildirim Jun 12 at 3:28
  • \$\begingroup\$ Some questions you might like to ask yourself: Is the EEPROM a new part? If it has ever been programmed using the software locked method, you will not be able to write to it using the hardware method you are using. Also, are you sure that your write pulse is really below 0.8V (VIL) for the required TWP period of 100ns? How are you applying the Data to the I/O pins - that does not seem to be shown on the schematic. \$\endgroup\$ – elchambro Jun 12 at 3:41
  • \$\begingroup\$ +1 for adding the schematic. Thank you \$\endgroup\$ – Adam Lawrence Jun 12 at 14:23
3
\$\begingroup\$

As per your description, you keep /CE high and that keeps the whole chip disabled. /CE must be low to enable read or write operations.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ I accidentally wrote that, sorry. /CE is low and it still doesn’t work. \$\endgroup\$ – Yigit_Yildirim Jun 10 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.