as per the title I'm using Nema23 stepper motor and 20:1 gear and tmc5126 stepper driver. 1) I'm providing 3amp of current to motor and 4096 of microstepping. 2) Motor was working on same configuration with RHINO 1101 external driver but not working with tmc5160. Am I missing something. Tried:- Without gear Motor working fine. No issue with motor.

Datasheet can be found here

  • \$\begingroup\$ Show is your schematic and describe the circumstances in a bit more detail. What mechanical load is applied to the motor/gear output and does it miss many steps all the time or just randomly over time? \$\endgroup\$ Jun 13, 2020 at 7:06
  • \$\begingroup\$ there is no load applied to it. Just gear with lead screw in it. It miss the steps all the time. It's not even rotating just missing steps with small noise. MotorWithGearis(bholanath.in/certificates-files/helical-worm-geared-TDS/…) \$\endgroup\$ Jun 13, 2020 at 8:05
  • 1
    \$\begingroup\$ So it is not rotating at all? Could you have connected the motor windings in the wrong order? It will make the motor just vibrate at best. \$\endgroup\$ Jun 13, 2020 at 11:02
  • \$\begingroup\$ Motor is not rotating it sleeping it's steps. I've connected and double checked the wiring also. I want to understand. 1) How to find what is maximum steps/mm we can give to the motor? 2) Maximum frequency controller/driver can provide to rotate biggest motor? 3) Increasing motor current will increase in torque is there anything else by which we can increase the torque? \$\endgroup\$ Jun 15, 2020 at 5:23
  • \$\begingroup\$ So I've tried 2x microstepping to 32x and also provided from 500 to 50,000 steps/mm sometimes it was just making small movement and with the noise from motor like slipping steps not moving forward. All of this while connected with 20:1 gear. \$\endgroup\$ Jun 15, 2020 at 5:32


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy