1
\$\begingroup\$

I have a few Segway Ninebot ES4 kickscooter controllers that I would like to learn how to fix.

Essentially at some point the motor ceased and seems to be fused, won't accelerate, won't brake, and even if power is off there is resistance in the motor rotation.

I narrowed it down to a blown MOSFET related to one of the motor leads. The MOSFET beeped with the continuity test so I concluded it was blown. I tried replacing the MOSFET, at first with one that had the same model number as the originals and after that blew as well I upgraded to a slightly more powerful MOSFET that blew as well.

The MOSFETs blow pretty much immediately after trying to ride the scooter. At first when I put everything back together, the motor spins freely, then when I try to ride it, immediately the motor starts vibrating and eventually dies in like 3 meters of riding. I can accelerate without load and seems to be fixed, but right after adding load, the motor starts vibrating and the MOSFET blows.

This is where I am stuck now, the same MOSFET keeps blowing. What is causing it to blow? Is it the MOSFET driver?

Has anyone here on this forum repaired Ninebot ES4 (or similar) motor controllers with the same issue? What can I try? I have two boards like this that I would like to learn how to fix this kind of issue with.

Info: Original MOSFETs on the board: NCEP01T13A (Tried replacing with same model from another dead controller) Secondly tried replacing with: IRF3808 (It was the closest match I could find that was sold in my country)

Pictures were to large to add directly but I did not want to lose quality so I put them on Google Drive for some time:

https://drive.google.com/drive/folders/1NZizmvtqdIiOTcaqg5oKKYEOSOMuvynv?usp=sharing

\$\endgroup\$
11
  • 1
    \$\begingroup\$ MOSFETs usually get damaged when they're overloaded, the current or voltage is too high. In your case chances are that the current becomes too high. It is unlikely that the MOSFET driver is at fault, if the driver is faulty, replacing the MOSFETs would not make things work again for a short time. My guess is that you should forget about the MOSFETs for a moment and look at the motor. The motor should not draw more current than the MOSFETs can handle. What is also possible is that there is an overcurrent detection that is broken. Include a schematic to see if that's the case. \$\endgroup\$ Jun 26, 2020 at 7:27
  • \$\begingroup\$ Thank you for the info. I will test different motors. Unfortunately I have not yet found a schematic for the boards, what I found: there are 4 types made in these scooters with slight variations, I have 2 of the 4 types with blown Mosfets. One looks like this (pic from google): content.invisioncic.com/r254450/monthly_2019_01/… I don't have my boards with me currently. If there is an overcurrent detection (there probably is with these controllers), what components on the board would it include? What can I test and swap? \$\endgroup\$
    – Ced495
    Jun 26, 2020 at 7:43
  • \$\begingroup\$ When you say you can accelerate with no load, do you mean that the wheels are off the floor? If it is working in this state, you could use an oscilloscope to look at the gate on each mosfet to see if they have a valid pwm signal. \$\endgroup\$
    – HandyHowie
    Jun 26, 2020 at 8:43
  • \$\begingroup\$ Yes, I mean off the floor. I would have to find an oscilloscope, that would take time but I will keep that in mind, thanks. Is a simple multimeter too slow to understand / measure a pwm signal? (I think it probably is.) \$\endgroup\$
    – Ced495
    Jun 26, 2020 at 9:11
  • \$\begingroup\$ They can also be destroyed from too much power dissipated. High current and high voltage are both fine as long as the other one is low. But medium current and medium voltage at the same time can also blow the MOSFET. And this could be caused by a MOSFET driver. @Bimpelrekkie \$\endgroup\$
    – user253751
    Jun 26, 2020 at 11:14

1 Answer 1

2
\$\begingroup\$

I see for D1X resistor can be seen darker/damaged, check it. See too for ceramic capacitor near mosfet and reisitor D1C bellow for cold solder and check/replace pulse diode. It is worth measuring or preferably replacing the current resistor R002 on the right side of the mosfet.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.