1
\$\begingroup\$

I'm currently trying to make a simple circuit to shutdown an IC (GPS SIM28ML). So I ended up with this: pmos circuit In green are the voltages measured when activating the NPN transistor, in blue the voltages measured when the NPN transistor is off.

Reading the datasheet of the PMOS, it says that the Vgs is from -0.3V to -1V. Then there is thi graph: Vgs graph

I dont understand what am I doing wrong, I tried searching in other posts before making this one but i still dont understand it.

EDIT: R2 goes to GND

\$\endgroup\$
1
\$\begingroup\$

If your GPIO is set at 0 volts, Q1 will be on and, if the GPIO is higher in voltage, Q1 will still be on. This means M1 will always be on: -

enter image description here

You need to connect R2 to ground and not 3.3 volts.

Alternatively, why don't you ditch Q1 and directly drive M1 from the GPIO via a 100 ohm resistor.

What load are you using and what voltage are you measuring across the load? Also double check you have fitted the correct MOSFET and that you have drain and source the correct way round. Double check these things.

Thanks for the help you provided me, the problem was the mosfet drain and source being the wrong way round. Now the circuit works with the 100ohm resitor just fine. I also tried the circuit with the npn transistor and it works too. So thank you, not only you helped me getting it to work but also to minimize parts list

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ I see that the R2 is actually to ground in the circuit I made, I'll edit the image. \$\endgroup\$ – Iván Gerber Jul 1 at 20:08
  • \$\begingroup\$ You say that M1 will always be on, how do I turn it off? can you help? Thank you \$\endgroup\$ – Iván Gerber Jul 1 at 20:13
  • \$\begingroup\$ Now you’ve made my answer look wrong. That’s the wrong way to go about asking for help. \$\endgroup\$ – Andy aka Jul 1 at 20:23
  • \$\begingroup\$ I'm sorry about that, it was not my intention \$\endgroup\$ – Iván Gerber Jul 1 at 21:13
  • \$\begingroup\$ I tried driving the pmos via 100ohm resistor as you said, but the result is the same. Could it be that the mosfet is not the right one for this 3.3v application? \$\endgroup\$ – Iván Gerber Jul 2 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.