1
\$\begingroup\$

I have a STM32WB55 custom board where I put the Read out Protection to level 1. I would like to change it back to level 0 as in this level, I am unable to program the PCB. I have tried using the ST LINK utility and the STM32Prog to change it back to level 0 but to no avail

STLINK Utility:

 Could not set Option bytes! 
    Please reset the target and retry. 
    Can not read memory! 
    Disable Read Out Protection and retry.

STM32 Prog :

Error: Expected value for Option Byte "RDP": 0xAA, found: 0xFF
Error: Option Byte Programming failed

From what I read online if my version of STLINK utility is higher than 4.0 it will work but it is not the case. Boot0 is at high and I have try reseting it but to no avail as well. Any ideas on how I can change it back?

\$\endgroup\$
5
  • 2
    \$\begingroup\$ Generally with erasing the entire chip \$\endgroup\$
    – uglyoldbob
    Jul 9, 2020 at 15:44
  • \$\begingroup\$ @uglyoldbob full chip erase works? \$\endgroup\$
    – jellybean
    Jul 9, 2020 at 15:45
  • \$\begingroup\$ why don't you try? \$\endgroup\$
    – muyustan
    Jul 9, 2020 at 15:49
  • \$\begingroup\$ @muyustan ive just tried and I cant as the read out protection prevents it \$\endgroup\$
    – jellybean
    Jul 9, 2020 at 15:50
  • \$\begingroup\$ Disabling readout protection does a full chip erase. But then you must FULLY POWER CYCLE THE BOARD before it takes effect. To make sure it's not still getting current leakage, disconnect everything - SWD, serial, USB, there should be no wires connected to the target at all. \$\endgroup\$ Jul 9, 2020 at 16:13

1 Answer 1

5
\$\begingroup\$

open ST-LINK utility-> go to Target -> Option Bytes then change the Read Out protection to level 0 Apply, then make a full chip erase. it has worked for me, hope this helps you

I found the answer in this link https://community.arm.com/developer/tools-software/tools/f/keil-forum/34824/can-t-disable-read-out-protection

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.