0
\$\begingroup\$

I am a newbie electronics learner and trying my hands on 555 timer to get it running in the monostable mode. Am trying the circuit as in the attached diagram. I am just unable to get the LED blink. I have tried the following troubleshooting steps:

  1. Tried with different LEDs. Made sure they work.
  2. Made sure replacing C1 capacitor with different values to ensure the capacitor is not faulty.
  3. Removing and replacing ceramic capacitor at pin 5 to make sure its not causing any issues.
  4. Trying various resistor and capacitor combinations; making sure that the pulse is not too short to be visible.
  5. Tried with 5 different 555 timers to eliminate the possibility of a faulty chip. Though they were all bought from the same vendor at the same time.

Given the reputation of the 555 timers and their proven history, most likely I am doing something wrong here. Can some one please suggest what could be missing? Ignore the spiral at the bottom of the picture, my two year old is learning with me how to draw electronic circuits.

enter image description here

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

EDIT 1:

Adding the pictures of my setup on breadboard. Battery is 9V, R1 - the resistor on PIN 7 is 96 K Ohms and the cylindrical capacitor is 1000 micro farads. There are 3 LEDs on the board. The two lighted LEDs on the power rails show that both the rails have power. The third one, connected to the output, has its negative terminal connected to ground power rail and positive terminal connected to pin 3 (output) of the timer for pulse. This LED is OFF in pictures and is not getting getting ON; but I have successfully tested it before and after taking the pictures; so it's a working LED. You can also see some other 555 timers at the bottom which I am trying alternatively.

I have tried it two ways.

Picture 1 and 2 (zoomed) show the setup where I am using a button to trigger the pin 2 of the timer.

Picture 3 shows the second way where instead of using a button, I am manually inserting the grey wire on pin 2 into the negative power rail for a brief time period to create the trigger.

Picture 4 just shows that the cylindrical capacitor's negative terminal is connected to the negative power rail.

Picture 1: Using a switch to generate trigger:

Using a switch

Picture 2: Using a switch to generate trigger - Zoomed:

Using a switch - Zoomed

Picture 3: Using a loose wire to generate trigger:

Using loose wire

Picture 4: Capacitor's negative terminal:

enter image description here

\$\endgroup\$
13
  • \$\begingroup\$ Your diagram looks fine, so show us your actual construction. What value(s) did you actually use for C1? Try disconnecting R1 to see whether the LED comes on and stays on when you trigger it. \$\endgroup\$
    – Dave Tweed
    Aug 13, 2020 at 1:15
  • \$\begingroup\$ I figured it out! It's because you spelled "Resistor" with an "e" ;) JK --- Seriously though, did you double check you got the polarity of your LED and your 1000uF cap correct??? When you draw a schematic, showing the polarity of those components is critical. Do you have your power-rails connected right? (They're drawn as +- on the left and -+ on the right) That could easily mess you up (It would mess me up!). It would be very helpful to post a picture of your circuit, not just your schematic. \$\endgroup\$
    – Kyle B
    Aug 13, 2020 at 1:31
  • \$\begingroup\$ Thanks @DaveTweed - I used 1000 micro farad for C1 most of the times. I will try disconnecting the R1 resistor and see what happens. Will report back. \$\endgroup\$
    – Anurag
    Aug 13, 2020 at 1:39
  • \$\begingroup\$ @KyleB - Thanks for looking at it. Sure, will post an actual picture of the breadboard later today. I think I have checked the polarity of the capacitor and LED and they seem fine. \$\endgroup\$
    – Anurag
    Aug 13, 2020 at 1:41
  • 1
    \$\begingroup\$ ^^^ It's a breadboard??? Note on most breadboards such as this: cdn.sparkfun.com/assets/learn_tutorials/4/7/… you have to make the power connections to each "rail" with a wire. (That gets new people all the time!) They often do not run the entire length of the board!!!!! Note where the red & blue lines are interrupted, these are NOT connected and you must make this connection external. Also, those breadboard are notorious for failing. Try moving your components to different tie-points \$\endgroup\$
    – Kyle B
    Aug 13, 2020 at 1:49

1 Answer 1

2
\$\begingroup\$

It appears that you have additional LEDs connected directly across the power rails without series resistors. These are dragging down the supply voltage to the point where the voltage at the output of the 555 is no longer sufficient to light its LED.

Get rid of those extra LEDs, or give them some series resistors too.

\$\endgroup\$
1
  • \$\begingroup\$ That's a great point, and if I hadn't been responding at 5AM, I'd probably have made the connection also ;) OP, what he's saying is the presence of those LEDs w/o resistors is "diode clamping" your voltage rails at around 4-4.5V (the forward voltage of the blue LEDs). However I think if this was "the problem", you'd see at least a TRICKLE of light in the target LED. It wouldn't be completely dark. \$\endgroup\$
    – Kyle B
    Aug 13, 2020 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.