I was using Altium 16 and generating PCB from schematics with no room generation. I have created my components library by mostly using "ultra librarian" files. I do these steps as many other times with no problems.

After this, I first run "design/update PCB doc.." from schematic view and when the process has ended my pcb components generation has this view:

enter image description here

As you can see, some components have fallen out of allowed display and I can not achieve the most of them in order to drop up them into an allowed area.

I have noticed that there are some components that are put under origin coordinates, so it is the maximum that display can achieve. It can not go down origini coordinates.

I have also noticed that some components has the designator is placed so far from its component footprint.

I removed the pcb document and restart the traslation, but no changes happened. I build a new project using the libs and schematic and start the traslation, but it results with the same way.

  • Have this happened to someone else?

  • Why can it be happening? Is it a sw bug?

  • How can it be solved in order to move and place the components from there?

Giving me some hints could be helpful for me.


2 Answers 2


This is a combination of multiple errors, some user-based and some bugs in the SW.

The reason your components are imported quite far from their designator is a problem with your libraries. This is due to where the origin-point of your component is located. It should usually be in the center of the component (or on Pin 1). If it instead is somewhere in a corner, you'll see this effect.

In earlier versions of Altium, there was a maximum leftmost and downmost point it was not possible to view beyond. This is not the origin-point, however. What I'd do then, is before importing any components I'd move the origin point to somewhere up and to the right.

This will mean that any components imported with an offset like this can be reached, as they'll be placed beyond the origin-point, but not beyond the maximum view-point.


The component with the designator at the end of the world made me to suspect from it. So, I tried one more thing: to recompile the project without this component at schematic. The result was fine!

Then I removed the "suspicious" footprint from my library and load it again, with the same name (but you can even change it). I put again the component on the same schematic and it works!

I don't know how the designators has moved this way before. I saw the origin in the center of the component; but strangely it was seen so small at preview when I opened it. Once I reloaded the footprint, this strange zoom out effect was disappeared and schematic updating was fixed.

Thanks for your attention.

I hope this problem and solution will be useful for someone at future. I spent too many time dealing with this.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.