6
\$\begingroup\$

I have drawn up a modest size schematic in KiCAD, for the first time.

It seemed more or less straight forward. But now that I run the ERC error checker, I get boatloads of errors with seemingly disconnected pins even though the automatic junctions appears. The most frequent error being:

"Pin connected to other pin but not driven"

enter image description here

It's random where it comes and where it doesn't even in setups that were copy pasted. Sometimes I need to unplug things and put them back together one by one, sometimes it's the little power components and sometimes the passive ones and sometimes I just move out the entire chip and put it back in. It sometimes fixes those problems and sometimes I rip my hair out doing it over and over and it just won't go away. Here is one on pin 1 of U24, no matter what I do it comes back. Similar problems on pins 2, 3, and 4 although they don't appear in the error box near this one.

This is very annoying and it must be bugs in KiCAD that is showing components connected, even with junctions, but the underlying model is apparently randomly different from what's shown.

Or can I just ignore those errors? And is there a way to tell the checker to ignore particular errors -- I know one can suppress classes of errors and warnings, but I mean particular occurrences of them. For example the second error (warning) "Conflict problem between pins ..." tri-state signal pin connected to fixed GND or +5V, the warning is fine once, but once I checked and find it correct, I want to acknowledge the particular warning and make it not be raised again, I don't want to see it any more. Same thing with disconnected pins, disconnected outputs shouldn't be a problem, I want to tell the checker that it is fine in particular cases.

\$\endgroup\$
  • \$\begingroup\$ I wouldn't claim that KiCAD doesn't have bugs, but I wouldn't expect drastic things. What version are you using? Do you have a place to put the project so that someone else could look at it? \$\endgroup\$ – JRE Aug 22 at 19:08
  • 2
    \$\begingroup\$ Do not ignore errors and warnings. If they come from bugs, then ignoring them has the potential to thoroughly mangle your PCB. If they are for real, then you need to fix them. Often times those warnings come from incorrect definitions on the pins. \$\endgroup\$ – JRE Aug 22 at 19:14
  • 1
    \$\begingroup\$ A couple of the errors you list are for a tri-state output connected to Power or Ground - perhaps you know that these pins will always be used as inputs, but KiCad doesn't. I would replace the direct Ground or Power connection with a 10K or so pull-up or pull-down resistor to Power or Ground to keep KiCad happy. \$\endgroup\$ – Peter Bennett Aug 22 at 19:15
  • \$\begingroup\$ I know nothing about the program, but what you have posted has shown me that it is complex enough that it has to be full of bugs. It can be "full of bugs" and still useful. \$\endgroup\$ – Ross Millikan Aug 23 at 4:24
12
\$\begingroup\$

Check that you have a "power output" pin driving the +5V net.

These errors typically occur when all that is connected to a power net are "power input" pins of various components, but there's nothing feeding power to the net. There needs to be either a "power output" pin (of a regulator or DC/DC or something), or a PWR_FLAG component connected to the net to mark that the power comes from an external source (such as a connector).

The EEschema manual says:

It is common to have an error or a warning on power pins, even though all seems normal. See example above. This happens because, in most designs, the power is provided by connectors that are not power sources (like regulator output, which is declared as Power out).

The ERC thus won’t detect any Power out pin to control this wire and will declare them not driven by a power source.

To avoid this warning you have to place a "PWR_FLAG" on such a power port. Take a look at the following example:

EEschema power flags example

The error marker will then disappear.

Most of the time, a PWR_FLAG must be connected to GND, because regulators have outputs declared as power out, but ground pins are never power out (the normal attribute is power in), so grounds never appear connected to a power source without a power flag symbol.

| improve this answer | |
\$\endgroup\$
8
\$\begingroup\$
  • I don't think KiCad is full of bugs (anymore).
  • It does lack the ability to waive violations individually. I believe this might be introduced in V6.
  • Not connected pins should always be marked as such. Use the Place no connection flag tool (looks like an X), keyboard shortcut is q.
  • You can change which errors are reported for each pin type. In the ERC tool, go to Options. There will be a matrix showing what connection types will give No error, Warning, or Error. (shown below).

enter image description here

| improve this answer | |
\$\endgroup\$
  • 1
    \$\begingroup\$ Thanks for the hint to the "not connected" flag. That solved this sub-problem. The major issue was solved by the power flag answer. \$\endgroup\$ – Gunther Schadow Aug 22 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.