0
\$\begingroup\$

My robot cleaner stopped charging after a week of not being used. I gave the same error as when I removed the battery. I then measured the voltage across the battery terminals, which is 0.01VDC.

I then pried open the case and measured the voltage across each battery, which is 4 VDC, so the batteries seem OK.

So I suspected the circuit is malfunctioning, and when I search for help, all I can find is how to revive dead batteries, nothing about the circuit.

Any tips on attempts to troubleshoot this or determine if the circuit is dead? It would be a shame trash the entire device its fixable.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ What voltage do you see across all 4 cells (not the terminals of the pack, but across the four cells in series)? What voltages show on the big soldering joints across the top of the PCB relative to ground? \$\endgroup\$ – ocrdu Aug 31 at 19:49
  • \$\begingroup\$ Failed BMS unless there is one cell with too low voltage. In that case, charge that one and see if the BMS becomes happy again. \$\endgroup\$ – winny Aug 31 at 21:57
  • \$\begingroup\$ V+ to V- shows 16VDC \$\endgroup\$ – Yoshidk Sep 1 at 5:53
  • \$\begingroup\$ Likely that BMS is faulty R has entered a shut down mode. Batteries sound OK. \$\endgroup\$ – Russell McMahon Sep 6 at 7:54
0
\$\begingroup\$

There are many things that can go wrong. For example, if the charger had tried to overcharge the pack, then the MCU on board had triggered the blowing of the fuse (FS1) that disconnected the charger. With such intervention, it has prevended the pack from exploding. So the problem might not be the battery pack, but the charger.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Good point, the chargers plate shows 17.1 VDC 1.1 A. But when I measure I only see 9.5VDC. So I guess the charger has died \$\endgroup\$ – Yoshidk Sep 1 at 5:52
  • 1
    \$\begingroup\$ Measure the fuse: dexerials.jp/en/products/c3/sfh0412.html \$\endgroup\$ – Marko Buršič Sep 1 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.