1
\$\begingroup\$

I got an old 420 watt Tagan power supply. It seems pretty good quality. I wanted to convert it into a bench power supply. It worked fine until I THINK I messed things up. I’m not sure if i actually damaged it or it was just too old and broke down. All I did was desolder a bunch of useless wires from the 3.3, 5, 12 volts and ground rails. After I connected it to a power source and measured the voltage at each rail, I found out that the 3.3 rails output was 5.20 volts!!! Why? Is there any way to fix it? Like replace any broken component. Also I did a continuity check between the 5 and 3.3 volt rail. There wasn't any short circuit.

\$\endgroup\$
12
  • \$\begingroup\$ Some old PSUs have cross regulation with combined feedback. You may have cut at least one of the feedback paths (e.g. damaging the tracks) while removing wires. \$\endgroup\$ – Rohat Kılıç Sep 1 '20 at 6:29
  • \$\begingroup\$ @RohatKılıç all the "useless" wires which i removed were connected to a single point for each kind of voltage. (3,3,5 12 Volts and ground) \$\endgroup\$ – Smoking Diesel GR Sep 1 '20 at 6:34
  • \$\begingroup\$ Is the 3.3V rail unloaded? If yes, can you try loading it? \$\endgroup\$ – winny Sep 1 '20 at 6:51
  • 2
    \$\begingroup\$ @DirkBruere i put some load on the power supply but still the voltage was 5.20. Before i desoldered those wires it worked fine \$\endgroup\$ – Smoking Diesel GR Sep 1 '20 at 7:33
  • 3
    \$\begingroup\$ @SmokingDieselGR The practise of Muntzing requires you to be able to undo the last change before the device stopped working. Can you re-solder the wires to find out which one is not useless? \$\endgroup\$ – Andrew Morton Sep 1 '20 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.