0
\$\begingroup\$

I have designed a boost converter based around the TPS61200 chip. This is a low voltage boost converter with a varying input of around 1.5V and 400mA.

The output of the circuit is 3.3V. However, when I connect a load (3.3V fan that draws 60mA) the voltage drops to 1.5V output. When I connected a motor (3V that draws 18mA) the voltage dropped to 50mV output!

I've also purchased an off the shelf module which experiences the same issue, so it's probably not my circuit design.

The components I'm using on the board are the following:

The off-the-shelf board is from SparkFun: https://www.sparkfun.com/products/10255 I shorted the UVLO as I didn't need it, and set it to 3.3V. I've also tried it on 5V and had the same issue.

The schematic for the circuit I designed: My circuit design

The schematic for the off-the-shelf module: Sparkfun module schematic

Thanks all for your help in advance. Cheers!

\$\endgroup\$
11
  • 1
    \$\begingroup\$ Show the schematic and link data sheets to parts used. \$\endgroup\$
    – Andy aka
    Commented Sep 2, 2020 at 13:55
  • \$\begingroup\$ Cheers for the advice. Added in schematics and datasheet links. \$\endgroup\$
    – Newbie
    Commented Sep 2, 2020 at 14:07
  • \$\begingroup\$ What voltage do you measure at the input under these conditions? What powers the input? What exact procedure was used to measure the current draw of the loads? \$\endgroup\$ Commented Sep 2, 2020 at 14:11
  • \$\begingroup\$ The input is around 1.5V 300mAh. A Peliter module is the source of power. The current draw is measured using a multi-meter in series with the load \$\endgroup\$
    – Newbie
    Commented Sep 2, 2020 at 14:12
  • 2
    \$\begingroup\$ And you measured that input voltage while the load was connected and the output was droopping? \$\endgroup\$ Commented Sep 2, 2020 at 14:14

1 Answer 1

0
\$\begingroup\$

I've just measured during load. The input voltage dropped to around 550mV during loading.

This indicates that your power source is simply not capable of supplying this load.

A boost converter cannot create power, it can only wastefully transform one voltage*current option to another having lesser total power.

\$\endgroup\$
2
  • \$\begingroup\$ It seems like I wasn't measuring voltage and current supply simultaneously from the power input. Once I've done tso and verified that this is the issue I'll mark as solved :) \$\endgroup\$
    – Newbie
    Commented Sep 2, 2020 at 15:01
  • \$\begingroup\$ Yep this was the case, under load the measured power of the polite module is far less than what it was when using the open circuit voltage. \$\endgroup\$
    – Newbie
    Commented Sep 2, 2020 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.