1
\$\begingroup\$

I am having trouble with a RF relay module that I bought off eBay, which I am using to control a 30A automotive relay to turn a 12V 20A trolling motor on/off. I’ve attached my circuit diagram below. When everything is hooked up the motor runs, so it seems to have continuity, however clicking the momentary switch on the transmitter doesn’t turn the motor off and back on like I believe it’s supposed to. When I click the transmitter switch the LED on the transmitter turns on, however I cannot get the LED on the receiver to turn on. There is a momentary switch on the receiver right below the LED, when clicked this doesn’t cause the LED to turn on either (I assume this switch is for programming). None of the connections are labeled NO,NC or C, but I assume C is the middle one and I also assume if I’ve wired it so that motor turns on then I’ve connected to the NO. When wired to the other connection the motor won’t turn on (and I can’t hear the 30A relay clicking on/off when disconnecting the battery, which happens on the other connection), so I assume this is the NC?

I’m wondering if the unit has a problem and isn’t receiving the RF transmission, or, am I making some obvious mistake? I’ve tried all possible wire combinations on the RF module, but haven’t touched the 30A relay because I’m relatively confident that is done correctly.

Thanks in advance!

enter image description here

\$\endgroup\$
2
  • \$\begingroup\$ If you want a decent answer, start by adding a decent schematic. You included a "hookup" diagram that only shows that you connected pin xy to yz. In a proper schematic it would be obvious what the function of each pin is, pin "86" means nothing to us. \$\endgroup\$ – Bimpelrekkie Sep 5 '20 at 13:52
  • \$\begingroup\$ @Bimpelrekkie you'll have to forgive me, I'm pretty new to this, I'm not sure how to draw up a proper schematic. I have talked to some other people about this online prior to this and no one mentioned they had difficulty understanding my "hookup" diagram. Since it was explained that I was using an automotive relay I guess I just assumed that if someone knows how to correctly wire a RF module it's pretty likely they will know how to hook up a car relay? \$\endgroup\$ – tim gavin Sep 6 '20 at 3:55
1
\$\begingroup\$

If the receiver has a relay, I would wait to connect the motor until I hear the relay clicking. Then, I would use a tester to identify the contacts.

You should read the instruction manual of the transmitter+receiver.

Most likely, you need to "teach" the receiver which remotes are allotted to communicate, and the button on the receiver serves that purpose: try to transmit while the button is depressed, or, try to keep it depressed a few second to enter learning mode (perhaps a LED starts blinking), or something like that (and that would be on the user manual...)

...AFTER THE COMMENT, SOME CLARIFICATION...

About the "wait to connect the motor": It was just a thought about not connecting powerful items before knowing that the system is working as intended: less things are connected, less problems you have, you can explore the system with more comfort. But in this case is not really important.

About "the tester": Sorry, a misnomer. In my language, a tester is a multimeter. Used in "continuity" (ohm) you can identify the contacts of a relay without breaking anything. Another precaution that, in your case, could be a little too much.

I looked at "similar items" in the ebay page you linked in your question. Citing "technical data" from what I've found (https://www.ebay.com.au/itm/DC-12V-10A-433MHz-4CH-Wireless-Relay-RF-Remote-Control-Switch-Receiver-oPTUKT-Y1/402351163728)

Encoding type: learning code (1527)

...means to me that the receiver must learn the transmitter(s). There is a lot of 433 Mhz transmitters around, the receiver must respond only to the intended one(s), so you must indicate to the receiver what transmitter it should acknowledge. You do that by make the receiver listen to your transmitter ("learn procedure"). I don't know what the number 1527 means, but I think this is not important.

Match code way: fixed code

Radio remote controls use mostly two systems: "fixed code" and "rolling code". The fixed type is simple and easy to duplicate; the "rolling code" is hard if not impossible. Remote controls for cars use the "rolling code" system, because they have to be hard to duplicate. Essentially "fixed code" means: the remote sends, always, the same (fixed) sequence of bits. Typically there are 12/24/32 bits. You can "listen" to those bits and replicate the sequence at will - easy. "Rolling code" means that every time the remote sends a different sequence: you can listen to that sequence, but that one is already invalid because the next time, the receiver will accept only a different one than before.

Now, in the (uh...) "technical data", I've found this:

  1. Learning method: Press the learning code for 3 seconds. The indicator will be off, and then loosen your finger, press any button of the remote control to transmit signal, the indicator flash 3 times and then normally on which means you learn it successfully.
  1. Remove/clean method: Press the learning button about 8 seconds, the indicator will be from being off to on all the time, it means the information that you keep have been removed successfully.

If the procedure depicted above does not work, try to post a photo of your receiver, I will try to identify the model to find the correct procedure. Of course your receiver can be broken, but probably not.

\$\endgroup\$
5
  • \$\begingroup\$ Thanks for replying. Unfortunately, there is no instruction manual for the unit. It didn't come with one and I cannot find anything online. I tried holding the button down for several seconds, and also pushing the transiever button while the receiver button was held down, but nothing. Would you be able to explain a bit more what you mean by "wait to connect the motor until I hear the relay clicking. Then, I would use a tester to identify the contacts." What exactly are you referring to as the tester and is this done using the little soldered points on the bottom of the PCB? \$\endgroup\$ – tim gavin Sep 6 '20 at 3:57
  • \$\begingroup\$ @timgavin I've updated the answer. Hope it is useful. \$\endgroup\$ – linuxfan says Reinstate Monica Sep 6 '20 at 5:27
  • \$\begingroup\$ Thanks for that explanation. I managed to find the part number of the receiver - it was half-hidden underneath some of the PCB components so I missed it before. It is kr1201-A and I've found the learning info online. However, even when pushing the correct combination of buttons on the receiver, the LED still doesn't light up. I removed everything and just have the receiver hooked up to 12V. It reads 12V on the receiver across where the wires are connected, so it's properly connected to the power supply. \$\endgroup\$ – tim gavin Sep 6 '20 at 8:42
  • \$\begingroup\$ Maybe one other thing worth mentioning is that I did modify the transmitter before wiring everything up. I added a bigger switch (so the transmitter can be sealed in a watertight container), which I soldered on. I assume this isn't a problem because when I hit that switch the LED on the transmitter comes on. It still comes on when I hit the original switch on the PCB as well. I have assumed that if that LED is turning on then there isn't a problem with the switch I soldered on - but maybe there is? I have tried both switches when attempting the learning code \$\endgroup\$ – tim gavin Sep 6 '20 at 8:47
  • \$\begingroup\$ @timgavin I think you are right about the switch. You could also try another remote, those receivers usually work with a big range of standard remotes. You could also try to check the voltage on the MCU of the receiver. \$\endgroup\$ – linuxfan says Reinstate Monica Sep 6 '20 at 15:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.