2
\$\begingroup\$

I am using Altium 20.1 and my question is regarding the sch library. I generated a schematic library and I want to use that as my default library for the components. When I try to update the schematic symbol, I see 2 sets of libraries : 1- imxbb.SCHLIB (unknown path. Is there a way to find it?) 2. IMX53_BB_1v2.SCHLIB (The one i generated and want to use)​​​​ ​​​enter image description here

I cannot add parameters to components because imxbb.SCHLIB does not show in the project tab

enter image description here

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

You will need to add your library to your project. The easiest method would probably be to right-click your project name and select "Add Existing to Project..." and browse to your library.

If you want to add libraries to be available to ALL of your projects, click on the gear in the upper right-hand corner ("Setup system Preferences") and under "System" select "Default Locations". enter image description here

enter image description here

The second path it asks for is the "Library Path", which allows you to enter a top-level directory in which your library files are located. Altium will search inside this directory recursively to find any libraries present.

enter image description here

Once selected, these libraries will appear in your "Components" panel when you're working inside the editor.

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.