0
\$\begingroup\$

I am automating some tests with Rigol hardware. There is only one bottleneck in the SCPI implementation that I can't figure out: How to enable the remote voltage-sense terminals on the Rigol DP3021 through SCPI commands.

It seems to be undocumented in the Rigol programming manual. I found some undocumented commands in this EEVBlog topic: the relevant command appears to be :REMote:SENSe:STATe

If I manually enable and disable the sense terminals, I can query this register :REMote:SENSe:STATe? and see the boolean status change as expected: 0/1 = Disable/Enable. However, if I write to this register :REMote:SENSe:STATe 1 the physical sense terminal does not change state unless I seize local-control and open the Utility menu. Only then does the device physically switch to the remote sense terminals - I can hear the relay click and the screen shows the status.

It's as if opening the Utility menu triggers some status update.

Can somebody with SCPI experience comment?

For now, my work-around will have to be to manually enable the sense terminal every time the device is powered-up. I'm honestly a little bummed out that this isn't documented in the programming manual as it seems to be such a fundamental function.

\$\endgroup\$
1
\$\begingroup\$

I had the exact same problem.

First check if you have the latest firmware and then use the latest datasheet, because yours is from 2017 and the latest is from April 2019 (programming guide).

The SCPI commands you are looking for are:

[:SOURce]:SENSe {0|1|ON|OFF} [:SOURce]:SENSe?

\$\endgroup\$
1
  • \$\begingroup\$ Fantastic - after all that I was just referring to the old programming manual. Thanks for your input, appreciate it! \$\endgroup\$ – Michael Oct 9 '20 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.