5
\$\begingroup\$

Why IC 4081 is taking seconds to set the ouput(11) to low whenever I detach either input (I'm using a breadboard so I'm just detaching cables, I still haven't figured out an good way to use a switch with that kind of board)?

  • Battery 6V (+.21)
  • R1 = 1KOhms
  • A simple LED
  • Average Current = .3mA

I'm bad at drawing =/ and gEDA represents the IC as a gate.

enter image description here

\$\endgroup\$
1
  • 1
    \$\begingroup\$ A link to the datasheet for your part would be helpful. \$\endgroup\$
    – The Photon
    Dec 28 '12 at 20:40
7
\$\begingroup\$

When you leave a CMOS input open anything can happen, including receiving mystical message in morse code.

Seriously, if you want a CMOS circuit to behave you MUST connect the input to a well-defined 0 or 1 level. Leaving it open is not OK.

\$\endgroup\$
1
  • \$\begingroup\$ @user17322 FWIW this is exactly what the earlier answer said, though that also lists a solution (a pullup resistor, to make the state defined even when the input is disconnected). \$\endgroup\$
    – exscape
    Dec 28 '12 at 21:28
1
\$\begingroup\$

To add to Wouter's answer, I would guess that the either the chip or some dust or oil or dirt on the chip has a tiny bit of internal leakage which is equivalent to a pull down resistor of several hundred megaohms to sever gigaohms.

The pins of the chip have a little tiny bit of capacitance. When you disconnect Vcc from the inputs, the charge remains on the pins until it discharges through whatever leakage mechanism is present, which takes several seconds.

If you were to connect the input directly to ground, or have a pull down resistor of a few kiloohms, response would likely be too fast to see without an oscilloscope.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.