I am trying to do boost converter with using mc34063 ic for my project. When I simulate the circuit on LTSpice with 3.7V input. I can get 5V output without any problem. However, when I change the input voltage to 4.2V (which is fully charged 3.7v 18650 lion battery voltage) I get 2.868V why this is happening? What is wrong? Is this a problem or not?

The whole circuit(red dotted area is the net where the probe I placed):

enter image description here

Output when the input voltage is 3.7v:

enter image description here

Output when the input voltage is 4.2v:

enter image description here

and this is the ltspice draft link itself:

  • \$\begingroup\$ There is a problem with the simulation. If you look closely at the circuit, you will see the minimum output voltage can not be any lower than the input voltage minus the diode drop. Because the simulation is saying the output voltage is much lower than that, I'm saying it is a simulation problem. \$\endgroup\$ Commented Oct 1, 2020 at 15:47
  • \$\begingroup\$ The Ltspice file is behind a paywall. \$\endgroup\$
    – TimWescott
    Commented Oct 1, 2020 at 15:47
  • \$\begingroup\$ By "red dotted area" you mean the red blob at the bottom right of the schematic? That's two diode drops below the regulated voltage, so your roughly three volts is consistent with the converter not running. What are the voltages at the DRC input and SWC output when the thing is running, and when it isn't? (SWC should be switching like mad, BTW). \$\endgroup\$
    – TimWescott
    Commented Oct 1, 2020 at 15:56
  • \$\begingroup\$ The output voltage is controlled by what the regulator sees at "Cinv". It has no idea what's going on much further down the chain. You have very little load in the area that's actually regulated, and a much heavier load where you're measuring. Try putting maybe 100 ohms load in the top output section, see if that brings your other voltages up. ALso as @TimWescott says, that area is behind two diode drops. I don't think it should be wired like that. Go for a more parallel structure. \$\endgroup\$
    – Kyle B
    Commented Oct 1, 2020 at 17:32
  • \$\begingroup\$ So, I tried to put a load on the voltage output node. However, there is nothing changed. I am agree that there maybe a simulation fault because there is no settling time for the circuit when I give 4.2V. It directly results the 2.868V. But when I give 3.7V on input, it iterates first and then gives the result graph. \$\endgroup\$
    – ratatosk
    Commented Oct 2, 2020 at 10:05

1 Answer 1


I selected different regulator ltc3426. Now it works.


enter image description here

Simulation: enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.