3
\$\begingroup\$

I have a question regarding ferrite beads. I have this kind of circuit:

enter image description here

Where IC1 and IC2 are digital ICs. The voltage supply for the opamps is obviously analog. I want to place a ferrite bead between the analog and digital side. I heard that it is best to place a ferrite bead between two decoupling caps (B). But in a lot of datasheets they place the ferrite bead between analog and digital supply (A).

  • Should I place the ferrite bead in point A or should I use multiple ferrite beads and place them in B?
\$\endgroup\$
3
  • \$\begingroup\$ There is no generic answer - it depends on the circuit detail. \$\endgroup\$ – Andy aka Oct 19 '20 at 14:02
  • 2
    \$\begingroup\$ Why do you want to place any inductance at all in the supply path? You are most probably best off with as low inductance as possible with strong planes for Vcc and GND and strong local decoupling. \$\endgroup\$ – winny Oct 19 '20 at 14:04
  • \$\begingroup\$ I don't want the high frequency digital noise to enter the analog supply. \$\endgroup\$ – electrococuk Oct 19 '20 at 14:05
1
\$\begingroup\$

It depends on the values in the analog section. If both are small (say, 0.1uF and 1000pF, the bead should be upstream. If one of them is bulk or bulk-ish (say, 4.7uF or 10uF) the bead should be downstream of it.

That’s a bit of an oversimplification of course.

This Murata application guide is useful: https://www.murata.com/~/media/webrenewal/support/library/catalog/products/emc/emifil/c39e.ashx

If your digital supply is very noisy, has a lot of ripple, or the analog is very sensitive, you might even consider a separate regulator for the analog part.

\$\endgroup\$
9
  • \$\begingroup\$ I am using 10µF and 0.1µF \$\endgroup\$ – electrococuk Oct 19 '20 at 14:09
  • \$\begingroup\$ The 10uF should be upstream of the ferrite then. It will be working at its best in the 10MHz range, while the ferrite starts working above that. \$\endgroup\$ – hacktastical Oct 19 '20 at 14:12
  • \$\begingroup\$ Lets say I am using seperate LDO's infront of the digital IC's and analog opamp's. Isn't it still good practice to use ferrite beads? \$\endgroup\$ – electrococuk Oct 19 '20 at 14:12
  • \$\begingroup\$ It’s a bit redundant. You’d put a single ferrite ahead of the LDO to block digital noise, but otherwise the rest of the analog could do without. That’s assuming you’ve carefully isolated the analog power runs so that there isn’t other coupling going on. \$\endgroup\$ – hacktastical Oct 19 '20 at 14:20
  • 1
    \$\begingroup\$ @electrococuk Ferrite beads can cause noise peaking and make things worse than if they were not there. You're supposed to check what noise frequencies are there before putting them in to make sure they don't fall into the peaking region and make things worse. Also note their extremely low saturation current (different than their current rating which is for heating). \$\endgroup\$ – DKNguyen Oct 19 '20 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.