1
\$\begingroup\$

I am trying to make some GameBoys use rechargeable LiPo batteries. I wanted to utilize a circuit that would allow me to play and charge at the same time and so I settled on the MCP73871.

https://ww1.microchip.com/downloads/en/DeviceDoc/MCP73871-Data-Sheet-20002090E.pdf

I purchased a circuit fabricated by diymore from eBay for about $2.80 a piece.

https://www.diymore.cc/products/mcp73871-usb-dc-solar-lipoly-lithium-lon-polymer-charger-3-7-4-2v-battery-module

Overview - I have the consoles connected via the LOAD section of the circuit, the battery on the BAT section, and a USB C connector on the PWR section.

I am new to electronics and have a few questions -

The circuit comes with a 4700 microfarad electrolytic capacitor. There is no way to fit this in any GameBoy model. According to the spec sheet it says 4.7 micro farad is plenty so I replaced it with a 4.7 microfarad tantalum capacitor which fit much better.

Is this replacement capacitor ok?

I purchased a 3.7v 4700mah LiPo battery for an original DMG GameBoy. Its quite overkill, but I thought it would be great to have a 60 hour battery life on the console.The board outputs 4.7 volts and this seems to be enough even though the system runs closer to 5 volts and might need more if I decide to use a backlight or IPS display. I have the circuit hooked up and powering the system via LiPo battery. I get the "charge in progress" status LEDs when charging the console, but its only pulling about 20 milliamps tops when charging/playing.

The system plays fine, but seems to not charge at any realistic current rate. I thought it was supposed to be 200 milliamps at minimum and up to 1amp. I even tried draining the battery to around 3.8 volts and it still doesn't charge more than 20 milliamps.

What have I done wrong that is causing such a low charge current?

If I need to bump up the current to somewhere above 5v and below 6v is it ok to add a step-up converter after the MCP73871 ? I think it has a built-in converter and I could replace that, but is having 2 bad?

I have done a similar mod on a GameBoy Color. It runs on 2.5v normally on 2x AA batteries, but seems to be running fine on a similar configuration. I purchased a 3.7v 2500mah battery. However it charges around the same rate 20 milliamp hours.

I am not sure why the circuit would ship with some kind of limitation where it only charges around 20 milliamps? What am I doing wrong? I get confused when I read the spec sheet and it seems by default charging should be at 200mah to 1 amp.

To measure milliamps I use a USB tester in between the supply and the circuit across the LOAD section. When I try to use my current measuring multimeter I get some odd readings, LED errors, and the chip heats up quite a bit. What am I doing wrong to measure current?

UPDATE

I got a 30V 5A power supply and I've been doing some more investigating.

It looks like I can only pull 50mA when I read with my meter. This makes me think its stuck in preconditioning. PROG has a 2KOhm resistor which should allow up to 500mA of charging current, but we don't seem to be getting there for some reason. When I crank the voltage above 5V the current can get to 150mA but that's nowhere near the 500mA or 1000mA fast charging rate.

\$\endgroup\$
8
  • \$\begingroup\$ i was not trying to be snarky ... you are asking what you did wrong with the multimeter, but you did not say what you did \$\endgroup\$
    – jsotola
    Nov 2 '20 at 6:17
  • \$\begingroup\$ I literally don't know what I am doing. Why would measuring current accross the load portion of the circuit cause the circuit to get upset and also result in circuit errors/shorts? The multimeter is set to milliamps and I am measuring accross the LOAD section on the circuit. \$\endgroup\$ Nov 2 '20 at 6:18
  • \$\begingroup\$ Anyways that's the least important question in the post. Any ideas why the charge current is so low? \$\endgroup\$ Nov 2 '20 at 6:45
  • 1
    \$\begingroup\$ it is not so unimportant ... it is unclear if the current is being measured correctly ... the meter has to be in series with the load \$\endgroup\$
    – jsotola
    Nov 2 '20 at 7:15
  • \$\begingroup\$ @DelightfulPear If you're measuring across the load with your multimeter set to current measurement (and assuming you've got the probes connected properly for current measurement) then you are creating a short circuit with your meter. Current measurement is done by placing the meter in series. \$\endgroup\$ Nov 6 '20 at 16:16
0
\$\begingroup\$

The Input Voltage for this Board is protected with a Diode to avoid wrong connection. This is useful for solar panels but in the USB case the voltage drop results in a too low Voltage related to the charge balancing circuit.

You should remove the diode and or solder a bridge

\$\endgroup\$
7
  • \$\begingroup\$ Wow thank you for this. So you’re saying usb voltage is too low compared to a solar panel? \$\endgroup\$ May 19 at 14:19
  • \$\begingroup\$ I also bought these. cdn-shop.adafruit.com/1200x900/4755-01.jpg. Do they have a similar diode? \$\endgroup\$ May 19 at 15:45
  • \$\begingroup\$ Ok I have done this and its pulling 271ma now. \$\endgroup\$ May 19 at 17:41
  • \$\begingroup\$ Now we're pulling 409ma! \$\endgroup\$ May 19 at 18:01
  • \$\begingroup\$ yes, the "1.5A USB/DC/Solar Charger" from Adafruit use a similar Diode in the USB-Path. But because they use another charging IC, there are no problems. \$\endgroup\$
    – Heinrich
    May 22 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.