1
\$\begingroup\$

I am trying to get video to work on STM32F769I device.

What I have done already is that I have changed the device tree so it has the required support and enabled the kernel features required for it to work, that resulted in /dev/fb0 framebuffer device.

If I write to framebuffer and save its contents it works perfectly fine, but its contents are not displayed on the screen, the only thing I see on the screen is ST splash screen and it would not change.

If I try to do any of the following the board hangs and I have to reboot it:

  • echo 0 0 > /sys/class/graphics/fb0/pan
  • cat /sys/class/graphics/fb0/modes > /sys/class/graphics/fb0/mode

Additional information print:

~ # for file in /sys/class/graphics/fb0/*; do echo "$file";  cat "$file"; done
/sys/class/graphics/fb0/bits_per_pixel
16
/sys/class/graphics/fb0/blank
/sys/class/graphics/fb0/console
/sys/class/graphics/fb0/cursor
/sys/class/graphics/fb0/dev
29:0
/sys/class/graphics/fb0/device
cat: read error: Is a directory
/sys/class/graphics/fb0/mode
/sys/class/graphics/fb0/modes
U:480x800p-0
/sys/class/graphics/fb0/name
stmdrmfb
/sys/class/graphics/fb0/pan
0,0
/sys/class/graphics/fb0/power
cat: read error: Is a directory
/sys/class/graphics/fb0/rotate
0
/sys/class/graphics/fb0/state
0
/sys/class/graphics/fb0/stride
1024
/sys/class/graphics/fb0/subsystem
cat: read error: Is a directory
/sys/class/graphics/fb0/uevent
MAJOR=29
MINOR=0
DEVNAME=fb0
/sys/class/graphics/fb0/virtual_size
480,800

Please help me get the display to work, I will gladly provide more info if requested.

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

Try this repo:

https://adrianalin.gitlab.io/popsblog.me/posts/build-linux-for-stm32f769i-disco-using-buildroot/

It works fine on my STM32F769I Discovery board.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.