1
\$\begingroup\$

I purchased two MLX90614 boards from aliexpress here.

They are both higher accuracy ( GY-906 DAA => 0.2°C, 3V) versions for medical instruments. I tried to hook one to Arduino nano (3.3V) but once hooked up, Arduino did not want to start. Upon investigation, I see that I am measuring zero resistance between Vin and GND. I presume it is faulty board, probably voltage regulator problem. However when I inspected the second board (that I did not yet hook to anything I measure similar thing - short circuit between Vin and GND).

Could there be anything that I might be missing other than that both boards are faulty?

Update, attaching photo per request, there is not much to see. MLX90614 breakout board GY-906

\$\endgroup\$
4
  • 6
    \$\begingroup\$ "Medical instruments" and "AliExpress" are not words that should go together. Measuring resistance of a board full of semiconductors gives very little useful information. \$\endgroup\$ – Transistor Nov 25 '20 at 7:45
  • \$\begingroup\$ I am aware that AliExpress is not a reliable source. I mentioned "medical" only because this is from the manufacturer specification - special version of the device with little higher precision, not because I would be using it for this purpose. However, one thing is that fake device is not up to specification, the other is that it does not work at all. I would still expect that resistance between Vin and GND is closer to 1 Mohm than to 0 ohm :). \$\endgroup\$ – Marko Nov 25 '20 at 8:23
  • \$\begingroup\$ Why not post (good and sharp) pictures of both sides of the boards? Did you look for obvious soldering issues? \$\endgroup\$ – Justme Nov 25 '20 at 8:28
  • \$\begingroup\$ Maybe you should post the manufacturer's specification: What to check for when buying an electronic component or module. Take note. \$\endgroup\$ – Andy aka Nov 25 '20 at 9:37
1
\$\begingroup\$

The sensors appear to be pretty simple to hook up. I don't see a lot of room for getting things wrong in the example circuits.

What I do notice is that the GY-906 DAA is in a metal can housing, and that the AliExpress modules show the housing sitting flush on the PCB.

Since the traces are also on that side, I'd take a look and see in the housing has cut into the solder stop over the traces. That could easily cause a short circuit between the Vin and ground connections.

If the housing is shorting the traces, then you could use a soldering iron to melt the solder pin by pin. For each pin, use a small screwdriver to lever the sensor up a little bit. Melt solder, lever up the sensor by that pin, hold in position, remove heat, let cool, go to the next pin. You don't need much clearance to fix the short.

It is also possible that the pins are shorted to the housing underneath. In that case, you'll have to completely remove the sensor from the board. Repeat the above procedure until the sensor pops out, then clean the solder from all the holes and the pins. Solder the sensor back in place. Don't flood things in solder, and make sure to pay attention to where the tab is.


The above assumes that there's a functional sensor on the board. Keep in mind that it is entirely possible that there are factory rejects or otherwise defective parts on the boards.

\$\endgroup\$
3
  • \$\begingroup\$ Thanks for the suggestion. I tried your suggestion, but unfortunately it seems the result is the same. Next thing to try is to desolder the sensor from the board and check if the issue is with the sensor or the board - if it is the board, then I will work something out - it is fairly simple breakout board. \$\endgroup\$ – Marko Nov 25 '20 at 10:00
  • 2
    \$\begingroup\$ It 's probably easier to remove the other parts one by one and check for short circuits there first. If none of the parts are shorted then try removing the sensor. \$\endgroup\$ – JRE Nov 25 '20 at 10:03
  • 1
    \$\begingroup\$ Thank JRE, after desoldering input capacitor (top right on the picture), the short is gone. Now I can measure around 5Mohm between Vin and GND. This looks promising, but now I have to move to other tasks. Still I will investigate further. \$\endgroup\$ – Marko Nov 25 '20 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.