2
\$\begingroup\$

I have a fresh installation of KiCad 5 on Windows 10 (no other version of KiCad was installed ever before, actually the computer is brand new). I have used KiCad a lot, but only on linux and I have never worked with version 5, which - I found out - has a different library management.

I'm facing the problem that there are no default footprint libraries neither in eeschema nor in pcbnew. When I installed KiCad I selected the option to copy all footprint libraries and in deed there are around 5 GB of footprints in C:\Program Files\KiCad\share\kicad\modules (note, that "Program Files" is "Programme" in the file explorer):

folder

I have configured a library path to this directory:

paths

When I try to simply add a footprint in pcbnew, the declared folder appears, but it does not contain the footprints:

selector

I can add a library by adding a path to the specific .pretty folder, but the default kicad modules consist of quite many of those. It doesn't feel right to start adding them all manually and also this was not neccessary on linux, where I have only few paths declared.

Question: How do I get access to the default kicad modules?

What I expected: After a fresh installation of KiCad, I can add footprints of the default kicad modules to a layout in eeschema without having configured anything.

\$\endgroup\$
2
\$\begingroup\$

When you start KiCad 5 for the first time, it should have prompted you with this dialog:

Configure Global Footprint Library Table

The recommended option copies the default library folders that you see in your Explorer window. It looks like you may have chosen the third option and ended up with an empty library table.

You can copy the default by hand. It is in C:\Program Files\KiCad\share\kicad\template\fp-lib-table. You can copy it to the locate you have blacked out in the top of the footprint library table window <user directory>\AppData\Roaming\kicad\

\$\endgroup\$
0
\$\begingroup\$

Though I'm pretty sure I checked the appropriate boxes on installation I had to add the libraries (.pretty folders) manually. I though this was a big hussle until I found out that in the add-library-dialogue it's possible to select all libraries and add them in one go (instead of adding them one-by-one).

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.