0
\$\begingroup\$

I'm trying to use a AMS1117 3.3V to deliver 3.3V from a 5V input.

Case 1. 5v input supplied from 5V output of usb power supply module pictured below Image of usb power supply module Works like a charm, 5V in and 3.3V out.

Case 2. 5V input supplied directly from micro usb output.

When the voltage regulator is not attached, the micro usb outputs 5V. When it is attached, this output goes down to 4.9V and the regulator outputs 4.2V.

Can anyone help me understand what is going on? The 5V output from the module passes through a chip with an underlined 4 on it. What does this chip do?

edit: schematic addedschematic

\$\endgroup\$
7
  • \$\begingroup\$ What equipment is the "micro usb output" in case 2 on? \$\endgroup\$ Nov 30 '20 at 12:13
  • \$\begingroup\$ Thanks Andrew, it's literally just a female micro usb smd soldered to some circuit board. Like in the image link images-na.ssl-images-amazon.com/images/I/… \$\endgroup\$
    – shnap
    Nov 30 '20 at 12:15
  • 1
    \$\begingroup\$ Need schematic for that PCB. \$\endgroup\$ Nov 30 '20 at 12:34
  • \$\begingroup\$ Hi Brian, the schematic for the micro usb? It's 5 pins with ground and 5V at the two ends. I've not connected any of the three data pins in the middle. Full details here sunrom.com/p/micro-usb-connector-b-female-5-pin-smd \$\endgroup\$
    – shnap
    Nov 30 '20 at 12:53
  • \$\begingroup\$ The AMS1117 is a chip, you need to show how it is connected on the board: you must supply a schematic. \$\endgroup\$ Nov 30 '20 at 13:31
1
\$\begingroup\$

Sounds like it is defective, assuming you've connected and measured it correctly.

The part you mention is a self-resetting fuse (maybe 0.5A rating) and should have minimal voltage drop in normal operation.

Check that there is not an open solder joint on the AMS1117 leads (esp. the left-hand one).

\$\endgroup\$
6
  • \$\begingroup\$ Thanks, what I don't understand is how it can work with one 5V input and not with the other. I have a whole pack of the AMS1117s and I've tried 4 all with the same results. \$\endgroup\$
    – shnap
    Nov 30 '20 at 12:17
  • \$\begingroup\$ Is anything other than a handheld battery-powered meter connected to the output (EITHER ground or 3.3V)? \$\endgroup\$ Nov 30 '20 at 12:18
  • \$\begingroup\$ No, just the meter. I've tried with and without capacitors between input and ground and output and ground as is recommended practice. \$\endgroup\$
    – shnap
    Nov 30 '20 at 12:21
  • \$\begingroup\$ Maybe a pinout error of some kind on the micro USB, like using pin 4 rather than pin 5? \$\endgroup\$ Nov 30 '20 at 12:34
  • \$\begingroup\$ Maybe, the micro usb still shows 5V on the voltmeter but I'm not sure what it would show if I'd caught the 4th pin, they're very small and my soldering iron is a bit chunky \$\endgroup\$
    – shnap
    Nov 30 '20 at 12:49
1
\$\begingroup\$

Thanks everyone, it was a bad solder on the usb side, the ground pin was touching the next pin along. I ended up cutting the data pins back to make sure that they weren't in the way.

\$\endgroup\$
3
  • \$\begingroup\$ Please don't add "thank you" as an answer. Instead, accept the answer that you found most helpful. - From Review \$\endgroup\$
    – SamGibson
    Nov 30 '20 at 18:40
  • \$\begingroup\$ shnap - Hi, Instead of adding this as an answer, it should be added as a comment on the answer you kindly accepted from Spehro. That answer already explained the possibility of a solder joint problem, so your answer is confirming that - hence it's just showing that the accepted answer was correct. \$\endgroup\$
    – SamGibson
    Nov 30 '20 at 18:46
  • \$\begingroup\$ Hi @SamGibson, I've left this in a comment under Spehro's response which I had already accepted as the answer. I think having the precise answer listed is useful to anyone searching for a solution to a similar problem but happy to delete it if it goes against the mod rules. \$\endgroup\$
    – shnap
    Dec 2 '20 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.