0
\$\begingroup\$

I’m struggling with AVX M830120 SMD GPS antenna in my project. I have used it in prototype board, did PCB layout more or less according to datasheet, and couldn’t get GPS fix no matter what I tried. I have soldered U.fl socket in place of this antenna, connected external ceramic patch antenna to my prototype board, and it works without any problems - I get GPS fix right away.

To rule out some design errors on my prototype board, i made test PCB with AVX M830120 antenna, microstrip feed line, and U.fl socket only, trying to exactly follow suggested PCB layout (solder patches are home made vias to ground plane on the other side of the PCB):

enter image description here

External ceramic patch antenna test setup:

enter image description here

Then i made S11 SVWR and S21 gain measurements with Nano VNA V2, comparing results from external ceramic patch antenna, and from my AVX antenna test PCB.

S21 for external ceramic patch antenna S21 external ceramic patch antenna

S21 for AVX M830120 test PCB S21 AVX M830120 test PCB

S11 SVWR for external ceramic patch antenna looks more or less as it should (it reaches value of 1 at expected GPS signal frequencies, has strange, sudden change of characteristic just in the middle of GPS band, but i can still get GPS fix with it!), but S11 SWVR for AVX one is completely unexpected, and it looks like it reflects a lot of signal back to the source, and doesn’t even resemble expected characteristic at 1.575 Ghz.

S11 for external ceramic patch antenna S11 external ceramic patch antenna

S11 for AVX M830120 test PCB S11 AVX M830120 test PCB

One maybe important thing is, that AVX antenna has this unique design, where feed line should also be connected to the ground:

AVX antenna layout suggestion from data sheet:

PCB layout suggestion

My questions (i'm definitely not an RF expert, as you can probably see from this post):

  • What can cause this strange S11 results from AVX antenna? Can it be that this specific antenna design (feed shorted to ground) makes it somehow impossible to do proper S11 measurement?

  • How this strange discrepancy between S11 and S21 for AVX antenna is possible? I would expect that if S11 looks like this, then S21 also should not resemble anything proper?

  • Can you use S11 at all to investigate parameters of receiving only antenna (as GPS one)?

  • Any ideas why this mediocre ceramic patch antenna works ok, and AVX one basically does not work at all? What mistakes i'm making here?

\$\endgroup\$

1 Answer 1

0
\$\begingroup\$

Problem was caused by unmatched impedances of AVX antenna and GPS module. After adding simple L matching network i finally was able to get GPS fix with AVX antenna.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.