0
\$\begingroup\$

I have a custom designed board that basically functions as an ethernet switch. On it I have 4 ports 3 with magnetics and 1 without magnetics. I could not use integrated magnetics on all of them because the last port is heavy duty and didn't come with that options.

The behavior I am seeing is that if I use any combination of the 3 with magnetics then I can connect to the internet just fine. All of them recognize in seconds. When I use the port with discrete magnetics the internet only works sometimes and without any real pattern as to when it will or will not work. Sometimes I can get connection by unplugging and replugging but there is no consistency.

Things I have tried/check:

  1. Differential pair impedance 0.25mm with 0.2mm between - same as all the other ports
  2. Tx/RX length matching - both pairs are within 5mm of each other.
  3. Changed out ports on board
  4. Tried different cables
  5. Unplugged and replugged on both laptop and board side. Will sometimes fix the problem but not reliably.
  6. Tried another board of the same design without any change.
  7. Inspected board for any assembly defect.

I really have no idea what could be the problem it seems to be a problem with my board but there is nothing I can think of.

EDIT: More specific details of what circuit entails.

  • Switch IC KSZ8895MQXCA
  • Mag Jacks: JDL-0011NL
  • Magnetics: TG110
  • Non-mag jack: MRJR-5381

Layout of area of interest enter image description here

Schematic of area of interest enter image description here

\$\endgroup\$
8
  • \$\begingroup\$ You can spend six months chasing something like this down. \$\endgroup\$
    – crasic
    Jan 7 at 22:07
  • 2
    \$\begingroup\$ How are we supposed to say what could be wrong, as you give literally no details to work with? What chips are used? Which magjacks? Which discrete magnetics and connector? Where are the schematics and PCB layout? \$\endgroup\$
    – Justme
    Jan 7 at 22:35
  • \$\begingroup\$ What does the MAC and PHY report? They might give a clue as to what the problem is. \$\endgroup\$
    – Kartman
    Jan 8 at 9:15
  • \$\begingroup\$ @Justme sorry about that I have updated my answer with more details about the actually configuration of the board. If I missed anything important let me know. \$\endgroup\$
    – jtrug
    Jan 8 at 13:20
  • 1
    \$\begingroup\$ So much for the isolation afforded by the magnetics being nulled by the pcb layout. \$\endgroup\$
    – Kartman
    Jan 8 at 15:36
1
\$\begingroup\$

The 8P8C connector J5 in your design uses pins 6 and 7 for the receive pair.

The receive pair is on pins 3 and 6 on standard Ethernet interface.

\$\endgroup\$
3
  • \$\begingroup\$ Magjack pinouts donnt always coincide with 8p8c numbering bc the transformers are on board. They should check the datasheet to confirm. \$\endgroup\$
    – crasic
    Jan 8 at 17:21
  • \$\begingroup\$ You are completely right - but that is not a magjack, the problem is specifically said to be on a non-magjack connector with discrete magnetics, as seen in the pictures. \$\endgroup\$
    – Justme
    Jan 8 at 17:30
  • \$\begingroup\$ You are exactly right! Kudos on your attention to their detail! further I thought your concern would be resolved with auto-mdi, pointing to a phy config problem . But it isn't just a simple swap, it really looks like they are getting away with losing half the pair when used alone, and this is not unusual with ethernet which can hobble along with quite a few direct hits. \$\endgroup\$
    – crasic
    Jan 8 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.