1
\$\begingroup\$

Recently for no reason at all some Altium shortcuts have stopped working, although not in all modes. For example, while placing anything in the schematic mode, pressing TAB no longer jumps to the properties panel but in PCB mode it still works. Another example, when moving a component, pressing X or Y no longer flips the component as it used to (only in the schematic mode, in PCB mode it still works fine). Instead X popups up the menu in the attached image, while Y does nothing.

pressing x while dragging a component

I tried restoring the settings from Tools -> Preferences -> Set to default (all) with no success.

Tested on Altium 20 and recently I upgrade to 21 with the problem persisting.

Any ideas?

Thanks

\$\endgroup\$
2
  • \$\begingroup\$ I'd ask my Altium FAE. \$\endgroup\$ Commented Jan 15, 2021 at 0:18
  • \$\begingroup\$ Obviously a question best asked of their support. If you Ctrl-left click on a drop-down menu item and scroll down to TAB (attempting to assign it as a shortcut key) it will tell you if it is otherwise assigned. Don't forget to restore to to <none>(!). \$\endgroup\$ Commented Jan 15, 2021 at 0:52

2 Answers 2

5
\$\begingroup\$

I did now have exact this problem, andf solved it doing this: Tools > Preferences > System > View > Desktop > Reset

enter image description here

\$\endgroup\$
1
  • \$\begingroup\$ Interesting how an unrelated setting affects another setting. Good job. \$\endgroup\$
    – John
    Commented Jun 2, 2021 at 21:36
0
\$\begingroup\$

I think I had a similar problem and I solved it:

  1. Toolbar right click and "customize":

enter image description here

2.

enter image description here

  1. Set "Shortcut Table" to true

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.