1
\$\begingroup\$

I connected three piezoelectric sensors to a rectifier which was further connected to a capacitor (100µF). I kept hitting the sensors for some time, and measured the voltage across the capacitor using a multi-meter. It displayed the voltage to be around 6 volts. Then, I used a breadboard to connect the capacitor, a resistor (100Ω ± 5%) and an LED bulb. The bulb didn't light up even for a fraction of a second. I measured the voltage across the capacitor again and found out that it had been discharged.

Any suggestions on how I can fix this?

\$\endgroup\$
9
  • 1
    \$\begingroup\$ how to fix what? \$\endgroup\$
    – jsotola
    Jan 23 at 8:20
  • 1
    \$\begingroup\$ What you have learned is that a 100uF capacitor doesn't store a lot of charge, and a piezoelectric sensor doesn't generate a lot of current/power. So if you want more usable amounts of electricity, you could connect hundreds of piezos to something that constantly vibrates and power a few small LEDs that way. What are you hoping for? If you want to make a light light up on impact you can amplify the signal from the sensor. Generating power with a piezo is more of a problem or it would be commonly done. \$\endgroup\$
    – K H
    Jan 23 at 8:39
  • \$\begingroup\$ Ah, you are telling us too many things at a time. Me IQ97 lost count at three. Now I suggest to eat the big elephant byte by byte in three or four bytes, starting the with the piezo. (1) So you hit the poor little piezo sensor with a hammer, and the piezo gets excited, generating electrons like a charged up capacitor. (2) Now the charged up piezo, say negative end, is connected to a capacitor through a rectifier, which lets electrons pass through but not allow them go back. (3) Now you use a multimeter and finds the capacitor charged up to 6V. So far so good eh? / to continue, ... \$\endgroup\$
    – tlfong01
    Jan 23 at 8:46
  • \$\begingroup\$ (4) Now let us look at the cap. If I remember correctly, the cap, after collecting the electrons (charges), should have an energy of 1/2 * (C * (V** 2)).= (100 * 10**-6) * (6V * 6V) (my always dodgy calculation is not proofread. :)) = (100 * 6 * 6 * 6) * (10**-6) ~= 21,000 micro Joule. (5) Now you connect the cap to a LED, which our stupid human eyes should see it growing red, if there is, say, current of 5mA, passing through it. (6) Now the starting discharging current should be big, something like V/R, where V = 6V, and R the "initial" resistance of the LED. / to continue, ... \$\endgroup\$
    – tlfong01
    Jan 23 at 9:08
  • 3
    \$\begingroup\$ @tlfong01, please don't answer questions in the comments. (But you know this already!) \$\endgroup\$
    – Transistor
    Jan 23 at 10:29
4
\$\begingroup\$

The bulb didn't light up even for a fraction of a second.

It probably did illuminate but, it would have done so for a small fraction of a second. For a capacitor, we can say this: -

$$Q = C\cdot V$$

And, if we differentiate charge (Q), we get current and rate of change of voltage: -

$$i = C\cdot\dfrac{dv}{dt}$$

So, if the LED is taking about 30 mA\$^{note1}\$, the rate at which the voltage collapses on the discharging capacitor is this: -

$$\dfrac{dv}{dt} = \dfrac{30\text{ mA}}{100\text{ μF}} = \text{300 volts per second}$$

So, assuming the LED needs at least 2 volts to operate and, the capacitor is charged up initially to 6 volts, then the LED lights for about 13 ms (give or take a few milliseconds).

You could try making the 100 Ω resistor a lot bigger (say 1 kΩ) so that there will only be about 3 mA flowing (on average) into the LED and it should still light but, it will still only light for maybe 130 ms. Turn the lights down to see it.


\$^{note1}\$ - The resistor in series with the LED is 100 Ω hence the initial current surge will be 40 mA, but I have used 30 mA as an approximate to the average level over the short time the LED illuminates. We could argue this one way or the other but, at the end of the day, the illumination duration will still be in the region of 10 to 20 ms.

\$\endgroup\$
2
\$\begingroup\$

Question

Why a 100μF capacitor, after being charged up to 6V, through a rectifier, by a repeatedly tapped piezo, cannot light up an LED?


Answer

Update 2021jan23hkt2150

To verify my guess that the capacitor has stored too little energy to light up the LED long enough for human to see, I did the following.

  1. Find a big cap 10,000μF, and fully charge it up using a 5V PSU (Yes, actually we don't need the piezo! :)).

  2. Disconnect PSU and let the capacitor alone supplies power to the LED.

  3. I see the LED grows brightly in the very beginning, but as the capacitor begins running out of "steam", gradually dims and goes dead, after about one minute.

This is the YouTube showing the capacitor discharging to 1kΩ and LED.

Youtube Video of a 10,000uF capacitor discharging to a 1kΩ and LED


I found the testing of LED input voltage vs current and brightness a bit tedious, besides not very reliable. So I assembled a simple test rig for quick and dirty testing, as shown below.

led test rig

Now I can test one combination of capacitance, V, I, brightness in less than 2 minutes. A very rough summary is given below:

  1. For cap at 5V, the diode current with 1k series resistor is roughly 3 ~ 3.5V for Red, Yellow, Green, but lower voltage for Blue and White. RGY lasts longer, BW dies fast. Red is the most efficient.

  2. For 10,000, 1,000, 470, 100uF, as expected big caps store more energy, so the LEDS grow loner. Very roughly, for 10,000, 1000, 470, 100uF, the light up time is very roughly tens of seconds, a couple of seconds (10, 5, 3) I surprisinglyly found that, even of the OP's cap value of 100uF, all my different types of LED can last 3 seconds. So I think the OP is not using super bright LEDs, or his caps are poor quality.

  3. One very surprising thing is that I found the 1W RGB 350mA power LEDs, do not different from the ordinary low power LEDs, when testing condition is around 3mA. So I think 1W 350 mA RGBYW LEDs are very flexible, can be used as orginary LED at low current < 20mA, and can scale up to high power with up to 350mA.

One very important conclusion I jumped to is the following. Since LED current varies drastically as even small change in voltage, it is difficult to control current and brightness (which is linear to current) by adjust voltage.

So now I appreciate very much why CCS (Constant Current Source) is used in almost all of non hobbyist application and projects. So I am stalling my testing at this point, because I am diverting to learning and playing with CCS stuff, and only come back after I have build up confidence in CCS skills.


The OP's questions is a bit complicated and needs a long answer.

(1) If you tap the piezo sensor repeatedly, the piezo becomes a charged capacitor.

(2) Now the charged up piezo with, say negative end, connected to a capacitor through a rectifier, which lets electrons pass through but not allow them go back.

(3) Now you use a multi-meter and finds the capacitor charged up to 6V.

(4) Now let us look at the capacitor. The cap should have an energy of 1/2 * (C * (V\$^{2}\$)).= (100 * 10\$^{-6}\$) * (6V * 6V) = (100 * 6 * 6 * 6) * (10\$^{-6}\$) ~= 21,000 μj (Joule) = 21mj.

(5) Now you connect the cap to a LED, which should grow red, if there is, say, current of 5mA, passing through it.

(6) Now the starting discharging current should be big, something like V/R, where V = 6V, and R the "initial" resistance of the LED.

(7) If the initial resistance R of the LED is too big, then the current passing through, by Ohme's Law, I = V/R might be smaller than 5mA, so the LED won't light up.

(8) And even the initial current is bigger than 5mA, the cap might run out of electrons pretty soon, perhaps in 10μs.

In other words, if the LED lights up for 10μS, human eyes won't notice the flick of light.

(8) There are a couple of workarounds: (a) use a tight string, say guitar string to hit the piezo, then you might see LED blinking, as the string repeatedly hits the piezo, charging and recharging the capacitor.

(9) Use a oscilloscope, to store the capacitor discharging waveform, and display it back in "slow motion".

(10) Protecting circuit from piezoelectric disc voltage spike - EESE Q&A.

(11) Piezo sensor picking up audio instrument signal - EESE Q&A.


\$\endgroup\$
2
  • 1
    \$\begingroup\$ Tip: use HTML entities &mu;, &Omega;, &omega, &deg;, etc. (They don't work in the comments though.) 'J' or 'joule' but not 'Joule'. 's' for 'second', 'S' for 'siemens' (conductance). \$\endgroup\$
    – Transistor
    Jan 23 at 12:03
  • \$\begingroup\$ @Transistor, many thanks for the tip, saves my time a lot. Cheers. \$\endgroup\$
    – tlfong01
    Jan 23 at 13:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.