0
\$\begingroup\$

Problem:

I have just moved my camera array USB peripheral from a MacBook Pro to a Raspberry Pi 400, and the Pi can only see at most 19 of the 24 cameras that the MacBook Pro can see. I think this is a power problem, and I am writing to check with people who are more knowledgable about such things.

Description of Hardware set up

I have a custom camera array made up of 24 USB cams, and 5 USB hubs. I had been successfully attaching this to my MacBook Pro, and all 24 cameras have been accessible via a USB port, without the need to provide additional power to the hubs.

I am now in the processing of porting this device to a Raspberry Pi 400.

When I now hook up this camera array to the Pi, it seems to be able to only access at most 19 cameras.

I am guessing that the reduced number of accessible cameras is a symptom of there not being enough power coming from the Raspberry Pi 400 to support all 24 cameras, while the MacBook Pro probably did supply enough power.

Is that a reasonable hypothesis?

If it might be the cause, should I increase the power flowing into the Raspberry Pi?

How should I determine how much additional power I should add (current supply is 5.1V 3A)?

Each of the hubs has an optional power input using a USB-C jack. So rather than providing the pi with more power, I could alternatively add extra power to the master USB Hub (USB Hub 5 in the attached diagram), and leave the power to the Pi unchanged.

Is there any advantage to powering the master hub directly?

Alternatively I can add power to each hub separately. I would have to the the DC power coming off a house current wall wart, and then divide it in parallel to each hub.

Is there any advantage to this approach of powering each hub independently?

I would only want to have one power cord coming in, so I would have to build a 5 way power cord splitter, so that's a disadvantage I see.

Data: With an in-line USB volt/amp meter, I am seeing that the normal Voltage and Amperage going through the meter when the Pi is idle is about

5.08-5.10V 0.27-0.30A Pi Idle

4.73V 1.30A Min Voltage and Peak amperage on Pi during camera polling

4.71-4.78V 1.33A MacBook Pro IDLE 4.71-4.78V 1.33A MacBook Pro during camera polling.

USB connections diagram. USB connections diagram.

UPDATE:

I have created the following graphs Voltage, Amperage and Wattage graphs for RPi and MBP during idle and camera polling periodsthat show how voltage and amperage change from idle state to when the cameras are being polled. The two lines with the large changes represent the Raspberry Pi tests, with the Normal 5.1V 3A power supply, and with a larger 96W power supply (same as used by MacBook Pro. The relatively stable line is from the MacBook Pro which shows no variation during camera polling.

I am guessing that the Raspberry Pi is limiting output to 5A - and that is apparently enough to power 18 of the 24 cameras. In contrast the MacBook Pro seems to happily supply more power (up to about 6.6A). That's the same ratio of 24/18, so that is probably why the Mac can power all the cameras, but the Pi cannot, even with additional power.

I am trying to find a way to supply the additional power directly to the hubs in hopes of working around this problem, but initial testing with additional power directly to the master hub, didn't resolve the problem.

\$\endgroup\$
2
  • \$\begingroup\$ Your diagram shows an LED string consuming 1.2A - disconnect it. If it really is a power problem then you'll see all the cameras with the LEDs disconnected. \$\endgroup\$
    – brhans
    Jan 24, 2021 at 3:55
  • \$\begingroup\$ I have removed the LED and updated the diagram. The problem remains unchanged. \$\endgroup\$ Jan 26, 2021 at 21:32

1 Answer 1

0
\$\begingroup\$

Use a powered USB hub for USB Hub 5.

That should provide a way to succesfully power all your devices and also allow A/B testing between Macbook and Raspberry PI, wile providing a consisten supply to the cameras allowing you to eliminate the possibility that it is actually a software problem.

\$\endgroup\$
5
  • \$\begingroup\$ I will power the master hub as you suggest. How can I determine how much wattage I should try using? \$\endgroup\$ Jan 24, 2021 at 5:12
  • \$\begingroup\$ do you have a usb power meter? \$\endgroup\$ Jan 24, 2021 at 8:10
  • \$\begingroup\$ I do have a USB power meter. I've uploaded charts that show the voltage, amperage and wattage consumed during both idle and camera polling activities, for both the Raspberry Pi that I am trying to get to work, and for the MacBook Pro powered tests that access all 24 cameras. \$\endgroup\$ Jan 26, 2021 at 10:20
  • \$\begingroup\$ I tried adding more power directly to the master hub, but initial testing has not shown this fixes the problem so far... \$\endgroup\$ Jan 26, 2021 at 10:22
  • \$\begingroup\$ I've completed testing with all and written it up here. Even with power to all the hubs, I am still not seeing all14 of the cameras. Any ideas? drive.google.com/file/d/1y_sqIuCasU-C1tlXPgnvH6F9eaT0cynv/… \$\endgroup\$ Feb 5, 2021 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.